summaryrefslogtreecommitdiff
path: root/gr-shd/swig/Makefile.am
diff options
context:
space:
mode:
authorTom Rondeau2011-11-27 19:06:15 -0500
committerTom Rondeau2011-11-27 19:06:15 -0500
commit355dbf5b35e2c4ebbce6c5d7d1ef5a3b0f5610ce (patch)
tree7dc1a7c47cfa2b23b31c1e68f5c2637b11186007 /gr-shd/swig/Makefile.am
parent70ca9beab2c6c22eb9b98818fe1b69def41eb0db (diff)
downloadgnuradio-355dbf5b35e2c4ebbce6c5d7d1ef5a3b0f5610ce.tar.gz
gnuradio-355dbf5b35e2c4ebbce6c5d7d1ef5a3b0f5610ce.tar.bz2
gnuradio-355dbf5b35e2c4ebbce6c5d7d1ef5a3b0f5610ce.zip
docs: Adding swig doc generation to Makefile.am files.
Diffstat (limited to 'gr-shd/swig/Makefile.am')
-rw-r--r--gr-shd/swig/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gr-shd/swig/Makefile.am b/gr-shd/swig/Makefile.am
index 3e155ba41..7f2cbd6be 100644
--- a/gr-shd/swig/Makefile.am
+++ b/gr-shd/swig/Makefile.am
@@ -48,6 +48,15 @@ endif
TOP_SWIG_IFILES = \
shd_swig.i
+TOP_SWIG_DOC_IFILES = \
+ shd_swig_doc.i
+
+BUILT_SOURCES = \
+ $(TOP_SWIG_DOC_IFILES)
+
+$(BUILT_SOURCES):
+ `echo "" > $@`
+
# Install so that they end up available as:
# import gnuradio.shd
# This ends up at: