summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau2011-12-30 13:49:14 -0500
committerTom Rondeau2011-12-30 13:49:14 -0500
commitdd84c8dfcb30617dbac56f49a57c1e363afe643b (patch)
treee6e4e71634dc4dc3f5e85ab5ff2c92e7ada8fa78 /CMakeLists.txt
parent0cdc6e67f575f6c86ad12734f87cf83aed72b102 (diff)
parent9838bb040af5eb21cd88dbc9aae8d4bdf2838854 (diff)
downloadgnuradio-dd84c8dfcb30617dbac56f49a57c1e363afe643b.tar.gz
gnuradio-dd84c8dfcb30617dbac56f49a57c1e363afe643b.tar.bz2
gnuradio-dd84c8dfcb30617dbac56f49a57c1e363afe643b.zip
Merge branch 'master' into next
Conflicts: gr-digital/examples/Makefile.am gr-digital/include/Makefile.am gr-digital/lib/Makefile.am gr-digital/python/Makefile.am gr-digital/swig/Makefile.am
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62eae906b..b6b5eb496 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,10 +124,20 @@ add_custom_target(uninstall
########################################################################
find_package(PythonLibs)
find_package(SWIG)
+
+if(SWIG_FOUND)
+ message(STATUS "Minimum SWIG version required is 1.3.31")
+ set(SWIG_VERSION_CHECK FALSE)
+ if("${SWIG_VERSION}" VERSION_GREATER "1.3.30")
+ set(SWIG_VERSION_CHECK TRUE)
+ endif()
+endif(SWIG_FOUND)
+
include(GrComponent)
GR_REGISTER_COMPONENT("python-support" ENABLE_PYTHON
PYTHONLIBS_FOUND
SWIG_FOUND
+ SWIG_VERSION_CHECK
)
find_package(CppUnit)