summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau2011-12-30 13:48:01 -0500
committerTom Rondeau2011-12-30 13:48:01 -0500
commit9838bb040af5eb21cd88dbc9aae8d4bdf2838854 (patch)
tree1e7b6af8dac4a6dae5774c8ae288564ae06f9dec /CMakeLists.txt
parent59ae7f87cc52e28a39b04895f2977624552f6f1d (diff)
parent6f0aee4f7a200f87c6fbe23c12fb01cbda872608 (diff)
downloadgnuradio-9838bb040af5eb21cd88dbc9aae8d4bdf2838854.tar.gz
gnuradio-9838bb040af5eb21cd88dbc9aae8d4bdf2838854.tar.bz2
gnuradio-9838bb040af5eb21cd88dbc9aae8d4bdf2838854.zip
Merge branch 'maint'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62eae906b..b6b5eb496 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,10 +124,20 @@ add_custom_target(uninstall
########################################################################
find_package(PythonLibs)
find_package(SWIG)
+
+if(SWIG_FOUND)
+ message(STATUS "Minimum SWIG version required is 1.3.31")
+ set(SWIG_VERSION_CHECK FALSE)
+ if("${SWIG_VERSION}" VERSION_GREATER "1.3.30")
+ set(SWIG_VERSION_CHECK TRUE)
+ endif()
+endif(SWIG_FOUND)
+
include(GrComponent)
GR_REGISTER_COMPONENT("python-support" ENABLE_PYTHON
PYTHONLIBS_FOUND
SWIG_FOUND
+ SWIG_VERSION_CHECK
)
find_package(CppUnit)