summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d8164cb..dec8fbf 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ import os
import sys
if sys.argv[-1] == 'publish':
- os.system('python setup.py sdist upload')
+ os.system('python setup.py register')
os.system('python setup.py sdist --formats=gztar,zip upload')
sys.exit()
@@ -23,7 +23,7 @@ with open('octave_kernel.py') as f:
lines = f.readlines()
for line in lines:
if line.startswith('__version__'):
- version = line.split()[-1]
+ version = line.split()[-1][1:-1]
svem_flag = '--single-version-externally-managed'
if svem_flag in sys.argv: