summaryrefslogtreecommitdiff
path: root/modules/windows_tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/windows_tools/Makefile.am')
-rwxr-xr-xmodules/windows_tools/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/modules/windows_tools/Makefile.am b/modules/windows_tools/Makefile.am
new file mode 100755
index 000000000..9da717403
--- /dev/null
+++ b/modules/windows_tools/Makefile.am
@@ -0,0 +1,46 @@
+# Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+# Copyright (C) 2007 - INRIA - Sylvestre LEDRU
+#
+# This file is distributed under the same license as the Scilab package.
+
+# List of the c files
+WINDOWS_TOOLS_C_SOURCES = src/nowindows_tools/nowindows_tools.c
+
+# Includes need for the compilation
+libsciwindows_tools_la_CPPFLAGS= -I$(srcdir)/includes/ \
+ -I$(srcdir)/src/c/ \
+ -I$(top_srcdir)/modules/api_scilab/includes/ \
+ -I$(top_srcdir)/modules/output_stream/includes/ \
+ $(AM_CPPFLAGS)
+
+# Name of the future library (.la will be replace by .so, .a, etc regarding
+# the system)
+
+if MAINTAINER_MODE
+pkglib_LTLIBRARIES = libsciwindows_tools.la
+else
+noinst_LTLIBRARIES = libsciwindows_tools.la
+endif
+
+
+# All the sources needed by libsciwindows_tools.la
+libsciwindows_tools_la_SOURCES = $(WINDOWS_TOOLS_C_SOURCES)
+
+#### Name of the module and the path ######
+modulename=windows_tools
+
+#### windows_tools : Conf files ####
+libsciwindows_tools_la_rootdir = $(mydatadir)
+libsciwindows_tools_la_root_DATA = license.txt
+
+#### windows_tools : init scripts ####
+libsciwindows_tools_la_etcdir = $(mydatadir)/etc
+libsciwindows_tools_la_etc_DATA = etc/windows_tools.quit etc/windows_tools.start
+
+#### windows_tools : gateway declaration ####
+libsciwindows_tools_la_sci_gatewaydir = $(mydatadir)/sci_gateway
+libsciwindows_tools_la_sci_gateway_DATA = sci_gateway/windows_tools_gateway.xml
+
+# Provides macros compilation, Java compilation, cleaning
+# If you want Makefile to call ant, added USEANT=1
+include $(top_srcdir)/Makefile.incl.am