summaryrefslogtreecommitdiff
path: root/modules/parallel/Makefile.am
diff options
context:
space:
mode:
authorShashank2017-05-29 12:40:26 +0530
committerShashank2017-05-29 12:40:26 +0530
commit0345245e860375a32c9a437c4a9d9cae807134e9 (patch)
treead51ecbfa7bcd3cc5f09834f1bb8c08feaa526a4 /modules/parallel/Makefile.am
downloadscilab_for_xcos_on_cloud-0345245e860375a32c9a437c4a9d9cae807134e9.tar.gz
scilab_for_xcos_on_cloud-0345245e860375a32c9a437c4a9d9cae807134e9.tar.bz2
scilab_for_xcos_on_cloud-0345245e860375a32c9a437c4a9d9cae807134e9.zip
CMSCOPE changed
Diffstat (limited to 'modules/parallel/Makefile.am')
-rwxr-xr-xmodules/parallel/Makefile.am70
1 files changed, 70 insertions, 0 deletions
diff --git a/modules/parallel/Makefile.am b/modules/parallel/Makefile.am
new file mode 100755
index 000000000..79316ffe9
--- /dev/null
+++ b/modules/parallel/Makefile.am
@@ -0,0 +1,70 @@
+# Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+# Copyright (C) 2010 - DIGITEO - Allan CORNET
+#
+# This file must be used under the terms of the CeCILL.
+# This source file is licensed as described in the file COPYING, which
+# you should have received as part of this distribution. The terms
+# are also available at
+# http://www.cecill.info/licences/Licence_CeCILL_V2.1-en.txt
+
+#PARALLEL_CXX_SOURCES =
+
+GATEWAY_CXX_SOURCES = sci_gateway/cpp/sci_parallel_run.cpp
+
+#PARALLEL_C_SOURCES =
+
+GATEWAY_C_SOURCES = sci_gateway/c/gw_parallel.c \
+sci_gateway/c/sci_parallel_concurrency.c
+
+libsciparallel_la_CPPFLAGS= $(OPENMP_CXXFLAGS) \
+-I$(srcdir)/includes/ \
+-I$(top_srcdir)/modules/core/includes/ \
+-I$(srcdir)/src/cpp/ \
+-I$(top_srcdir)/modules/api_scilab/includes/ \
+-I$(top_srcdir)/modules/localization/includes/ \
+-I$(top_srcdir)/modules/string/includes/ \
+-I$(top_srcdir)/modules/output_stream/includes/ \
+-I$(top_srcdir)/modules/parameters/includes/ \
+-I$(top_srcdir)/modules/dynamic_link/includes/ \
+$(AM_CPPFLAGS)
+
+
+pkglib_LTLIBRARIES = libsciparallel.la
+
+libsciparallel_la_LIBADD = $(OPENMP_LIBS)
+
+if OPENMP
+libsciparallel_la_SOURCES = $(GATEWAY_C_SOURCES) $(GATEWAY_CXX_SOURCES)
+
+else
+libsciparallel_la_SOURCES = src/noparallel/noparallel.h \
+src/noparallel/noparallel.c
+endif
+
+# For the code check (splint)
+CHECK_SRC= $(PARALLEL_C_SOURCES) $(GATEWAY_C_SOURCES)
+INCLUDE_FLAGS = $(libsciparallel_la_CPPFLAGS)
+
+#### Target ######
+modulename=parallel
+
+#### parallel : Conf files ####
+libsciparallel_la_rootdir = $(mydatadir)
+libsciparallel_la_root_DATA = license.txt
+
+
+#### parallel : init scripts ####
+libsciparallel_la_etcdir = $(mydatadir)/etc
+libsciparallel_la_etc_DATA = etc/parallel.quit etc/parallel.start
+
+#### parallel : gateway declaration ####
+libsciparallel_la_sci_gatewaydir = $(mydatadir)/sci_gateway
+libsciparallel_la_sci_gateway_DATA = sci_gateway/parallel_gateway.xml
+
+#### parallel : include files ####
+libsciparallel_la_includedir=$(pkgincludedir)
+libsciparallel_la_include_HEADERS =
+
+include $(top_srcdir)/Makefile.incl.am
+
+