summaryrefslogtreecommitdiff
path: root/modules/atoms/Makefile.am
diff options
context:
space:
mode:
authorShashank2017-05-29 12:40:26 +0530
committerShashank2017-05-29 12:40:26 +0530
commit0345245e860375a32c9a437c4a9d9cae807134e9 (patch)
treead51ecbfa7bcd3cc5f09834f1bb8c08feaa526a4 /modules/atoms/Makefile.am
downloadscilab_for_xcos_on_cloud-0345245e860375a32c9a437c4a9d9cae807134e9.tar.gz
scilab_for_xcos_on_cloud-0345245e860375a32c9a437c4a9d9cae807134e9.tar.bz2
scilab_for_xcos_on_cloud-0345245e860375a32c9a437c4a9d9cae807134e9.zip
CMSCOPE changed
Diffstat (limited to 'modules/atoms/Makefile.am')
-rwxr-xr-xmodules/atoms/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/modules/atoms/Makefile.am b/modules/atoms/Makefile.am
new file mode 100755
index 000000000..db2f3aff9
--- /dev/null
+++ b/modules/atoms/Makefile.am
@@ -0,0 +1,39 @@
+# Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+# Copyright (C) 2009 - DIGITEO
+#
+# This file must be used under the terms of the CeCILL.
+# This source file is licensed as described in the file COPYING, which
+# you should have received as part of this distribution. The terms
+# are also available at
+# http://www.cecill.info/licences/Licence_CeCILL_V2.1-en.txt
+
+modulename=atoms
+
+#### atoms : Conf files ####
+libsciatoms_la_rootdir = $(mydatadir)
+libsciatoms_la_root_DATA = license.txt
+
+#### atoms : init scripts ####
+libsciatoms_la_etcdir = $(mydatadir)/etc
+libsciatoms_la_etc_DATA = etc/atoms.quit etc/atoms.start etc/repositories
+
+#### atoms : XML gui ####
+libsciatoms_la_guidir = $(mydatadir)/gui
+libsciatoms_la_gui_DATA = gui/atomsGui.xml
+
+#### atoms : internal functions ####
+MACROSDIRSEXT = macros/atoms_internals macros/atoms_gui
+
+#### atoms : icons files ####
+#
+# Generated with:
+# $ find images/ -type f -printf "%p \\\\\n" -name *.svg -or -name *.gif -or -name *.jpg -or -name *.png |sort -u
+libsciatoms_la_iconsdir=$(mydatadir)/
+nobase_libsciatoms_la_icons_DATA = images/icons/16x16/emblems/emblem-default.png \
+images/icons/16x16/status/dialog-information.png \
+images/icons/16x16/status/software-update-available.png \
+images/icons/16x16/status/software-update-installed.png \
+images/icons/16x16/status/software-update-notinstalled.png \
+images/icons/16x16/status/software-update-notuptodate.png
+
+include $(top_srcdir)/Makefile.incl.am