summaryrefslogtreecommitdiff
path: root/src/string/string/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/string/string/Makefile.am')
-rw-r--r--src/string/string/Makefile.am55
1 files changed, 51 insertions, 4 deletions
diff --git a/src/string/string/Makefile.am b/src/string/string/Makefile.am
index 695a95bb..9c503953 100644
--- a/src/string/string/Makefile.am
+++ b/src/string/string/Makefile.am
@@ -1,8 +1,55 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Allan SIMON
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
-bin_PROGRAMS = \
- string.h
+libString_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/string/includes
-string_h_SOURCES =
+pkglib_LTLIBRARIES = libString.la
-## File created by the gnome-build tools
+libString_la_SOURCES = $(HEAD) $(SRC)
+SRC = sstrings.c \
+ dstrings.c \
+ cstrings.c \
+ zstrings.c \
+ sstringa.c \
+ dstringa.c \
+ cstringa.c \
+ zstringa.c
+
+HEAD = ../includes/string.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/string/includes \
+ -I $(top_builddir)/type
+
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/string/string/libString.la
+
+check_PROGRAMS = testFloatString testDoubleString
+
+TESTS = testFloatString testDoubleString
+
+#
+# -*- Dispine Tests -*-
+#
+testFloatString_SOURCES = testString.h testFloatString.c
+testFloatString_CFLAGS = $(check_INCLUDES)
+testFloatString_LDADD = $(check_LDADD)
+
+testDoubleString_SOURCES = testString.h testDoubleString.c
+testDoubleString_CFLAGS = $(check_INCLUDES)
+testDoubleString_LDADD = $(check_LDADD)