summaryrefslogtreecommitdiff
path: root/src/signalProcessing/conv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/signalProcessing/conv/Makefile.am')
-rw-r--r--src/signalProcessing/conv/Makefile.am77
1 files changed, 77 insertions, 0 deletions
diff --git a/src/signalProcessing/conv/Makefile.am b/src/signalProcessing/conv/Makefile.am
new file mode 100644
index 00000000..c5196231
--- /dev/null
+++ b/src/signalProcessing/conv/Makefile.am
@@ -0,0 +1,77 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008 - INRIA - Arnaud TORSET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+
+
+
+libConv_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/operations/includes \
+ -I $(top_builddir)/signalProcessing/fft \
+ -I $(top_builddir)/signalProcessing/ifft \
+ -I $(top_builddir)/signalProcessing/includes
+
+
+instdir = $(top_builddir)/lib
+
+
+pkglib_LTLIBRARIES = libConv.la
+
+HEAD = ../includes/conv.h \
+ ../fft/fft_internal.h \
+ ../ifft/fft_internal.h
+
+
+
+libConv_la_SOURCES = $(HEAD) \
+ sconva.c \
+ dconva.c \
+ cconva.c \
+ zconva.c
+
+
+###############
+#### Check ####
+###############
+
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/operations/multiplication/libMultiplication.la \
+ $(top_builddir)/signalProcessing/ifft/libIfft.la \
+ $(top_builddir)/signalProcessing/fft/libFft.la \
+ $(top_builddir)/lib/lapack/libscilapack.la \
+ $(top_builddir)/lib/blas/libsciblas.la \
+ $(top_builddir)/operations/addition/libAddition.la \
+ $(top_builddir)/operations/subtraction/libSubtraction.la \
+ libConv.la
+
+
+check_INCLUDES = -I $(top_builddir)/type \
+ -I $(top_builddir)/operations/includes \
+ -I $(top_builddir)/signalProcessing/fft \
+ -I $(top_builddir)/signalProcessing/ifft \
+ -I $(top_builddir)/signalProcessing/includes
+
+check_PROGRAMS = testFloatConv testDoubleConv
+
+TESTS = testFloatConv testDoubleConv
+
+
+testDoubleConv_SOURCES = testDoubleConv.c
+testDoubleConv_LDADD = $(check_LDADD)
+testDoubleConv_CFLAGS = $(check_INCLUDES)
+
+testFloatConv_SOURCES = testFloatConv.c
+testFloatConv_LDADD = $(check_LDADD)
+testFloatConv_CFLAGS = $(check_INCLUDES)
+
+
+