summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/tan/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/tan/Makefile.am')
-rw-r--r--src/elementaryFunctions/tan/Makefile.am30
1 files changed, 14 insertions, 16 deletions
diff --git a/src/elementaryFunctions/tan/Makefile.am b/src/elementaryFunctions/tan/Makefile.am
index b48157b3..f4e6052a 100644
--- a/src/elementaryFunctions/tan/Makefile.am
+++ b/src/elementaryFunctions/tan/Makefile.am
@@ -1,25 +1,23 @@
##
-## -*- makefile -*-
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Bruno JOFRET
##
-## Makefile
-## Made by Bruno JOFRET <bruno.jofret@inria.fr>
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
##
-## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Wed Apr 18 16:51:17 2007 jofret
-##
-## Copyright INRIA 2007
##
-AM_CFLAGS = -I ../../type \
- -I ../includes
+libTan_la_CFLAGS = -I ../../type \
+ -I ../includes
instdir = $(top_builddir)/lib
-inst_LIBRARIES = libTan.a
-
-noinst_LIBRARIES = libTan.a
+pkglib_LTLIBRARIES = libTan.la
-libTan_a_SOURCES = $(HEAD) $(SRC)
+libTan_la_SOURCES = $(HEAD) $(SRC)
SRC = stans.c \
dtans.c \
@@ -48,7 +46,7 @@ TESTS = testTan
#
testTan_SOURCES = testTan.c
testTan_CFLAGS = $(check_INCLUDES)
-testTan_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
- $(top_builddir)/lib/libFloatComplex.a \
- $(top_builddir)/lib/libTan.a \
+testTan_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/elementaryFunctions/tan/libTan.la \
@LIBMATH@