summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/sqrt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/sqrt/Makefile.am')
-rw-r--r--src/elementaryFunctions/sqrt/Makefile.am65
1 files changed, 0 insertions, 65 deletions
diff --git a/src/elementaryFunctions/sqrt/Makefile.am b/src/elementaryFunctions/sqrt/Makefile.am
deleted file mode 100644
index 978c84e0..00000000
--- a/src/elementaryFunctions/sqrt/Makefile.am
+++ /dev/null
@@ -1,65 +0,0 @@
-##
-## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
-## Copyright (C) 2007-2008 - INRIA - Bruno JOFRET
-##
-## This file must be used under the terms of the CeCILL.
-## This source file is licensed as described in the file COPYING, which
-## you should have received as part of this distribution. The terms
-## are also available at
-## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
-##
-##
-
-libSqrt_la_CFLAGS = -I $(top_builddir)/type \
- -I $(top_builddir)/elementaryFunctions/includes \
- -I $(top_builddir)/auxiliaryFunctions/includes \
- -I $(top_builddir)/operations/includes
-
-instdir = $(top_builddir)/lib
-
-pkglib_LTLIBRARIES = libSqrt.la
-
-libSqrt_la_SOURCES = $(HEAD) $(SRC)
-
-SRC = ssqrts.c \
- dsqrts.c \
- csqrts.c \
- zsqrts.c \
- ssqrta.c \
- dsqrta.c \
- csqrta.c \
- zsqrta.c
-
-HEAD = ../includes/sqrt.h
-
-####
-# Checking Part
-####
-
-check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
- -I $(top_builddir)/type
-
-check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/operations/addition/libAddition.la \
- $(top_builddir)/lib/lapack/libscilapack.la \
- $(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
- $(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
- $(top_builddir)/auxiliaryFunctions/pythag/libPythag.la \
- $(top_builddir)/operations/multiplication/libMultiplication.la \
- @LIBMATH@
-
-check_PROGRAMS = testFloatSqrt testDoubleSqrt
-
-TESTS = testFloatSqrt testDoubleSqrt
-
-#
-# -*- Square Root Tests -*-
-#
-testFloatSqrt_SOURCES = testSqrt.h testFloatSqrt.c
-testFloatSqrt_CFLAGS = $(check_INCLUDES)
-testFloatSqrt_LDADD = $(check_LDADD)
-
-testDoubleSqrt_SOURCES = testSqrt.h testDoubleSqrt.c
-testDoubleSqrt_CFLAGS = $(check_INCLUDES)
-testDoubleSqrt_LDADD = $(check_LDADD)