summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/cos/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/cos/Makefile.am')
-rw-r--r--src/elementaryFunctions/cos/Makefile.am26
1 files changed, 16 insertions, 10 deletions
diff --git a/src/elementaryFunctions/cos/Makefile.am b/src/elementaryFunctions/cos/Makefile.am
index 43ec1282..362c1fe4 100644
--- a/src/elementaryFunctions/cos/Makefile.am
+++ b/src/elementaryFunctions/cos/Makefile.am
@@ -37,19 +37,25 @@ HEAD = ../includes/cos.h
check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/type
-check_PROGRAMS = testCos
-
-TESTS = testCos
-
-#
-# -*- Cosine Tests -*-
-#
-testCos_SOURCES = testCos.c
-testCos_CFLAGS = $(check_INCLUDES)
-testCos_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/elementaryFunctions/cos/libCos.la \
$(top_builddir)/elementaryFunctions/sin/libSin.la \
$(top_builddir)/elementaryFunctions/cosh/libCosh.la \
$(top_builddir)/elementaryFunctions/sinh/libSinh.la \
@LIBMATH@
+
+check_PROGRAMS = testFloatCos testDoubleCos
+
+TESTS = testFloatCos testDoubleCos
+
+#
+# -*- Cosine Tests -*-
+#
+testFloatCos_SOURCES = testFloatCos.c
+testFloatCos_CFLAGS = $(check_INCLUDES)
+testFloatCos_LDADD = $(check_LDADD)
+
+testDoubleCos_SOURCES = testDoubleCos.c
+testDoubleCos_CFLAGS = $(check_INCLUDES)
+testDoubleCos_LDADD = $(check_LDADD) \ No newline at end of file