summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/atanh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/atanh/Makefile.am')
-rw-r--r--src/elementaryFunctions/atanh/Makefile.am68
1 files changed, 0 insertions, 68 deletions
diff --git a/src/elementaryFunctions/atanh/Makefile.am b/src/elementaryFunctions/atanh/Makefile.am
deleted file mode 100644
index c057f9ba..00000000
--- a/src/elementaryFunctions/atanh/Makefile.am
+++ /dev/null
@@ -1,68 +0,0 @@
-##
-## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
-## Copyright (C) 2008-2008 - INRIA - Bruno JOFRET
-##
-## This file must be used under the terms of the CeCILL.
-## This source file is licensed as described in the file COPYING, which
-## you should have received as part of this distribution. The terms
-## are also available at
-## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
-##
-##
-
-libAtanh_la_CFLAGS = -I ../../type \
- -I ../includes
-
-instdir = $(top_builddir)/lib
-
-pkglib_LTLIBRARIES = libAtanh.la
-
-libAtanh_la_SOURCES = $(HEAD) $(SRC)
-
-SRC = satanhs.c \
- datanhs.c \
- catanhs.c \
- zatanhs.c \
- satanha.c \
- datanha.c \
- catanha.c \
- zatanha.c
-
-HEAD = ../includes/atanh.h
-
-####
-# Checking Part
-####
-
-check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
- -I $(top_builddir)/auxiliaryFunctions/includes \
- -I $(top_builddir)/type
-
-check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/operations/addition/libAddition.la \
- $(top_builddir)/lib/lapack/libscilapack.la \
- $(top_builddir)/elementaryFunctions/atan/libAtan.la \
- $(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
- $(top_builddir)/elementaryFunctions/atanh/libAtanh.la \
- $(top_builddir)/elementaryFunctions/lnp1m1/libLnp1m1.la \
- $(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
- $(top_builddir)/auxiliaryFunctions/pythag/libPythag.la \
- $(top_builddir)/operations/multiplication/libMultiplication.la \
- $(top_builddir)/auxiliaryFunctions/isnan/libIsnan.la \
- @LIBMATH@
-
-check_PROGRAMS = testFloatAtanh testDoubleAtanh
-
-TESTS = testFloatAtanh testDoubleAtanh
-
-#
-# -*- Hyperbolic ArcTangeant Tests -*-
-#
-testFloatAtanh_SOURCES = testAtanh.h testFloatAtanh.c
-testFloatAtanh_CFLAGS = $(check_INCLUDES)
-testFloatAtanh_LDADD = $(check_LDADD)
-
-testDoubleAtanh_SOURCES = testAtanh.h testDoubleAtanh.c
-testDoubleAtanh_CFLAGS = $(check_INCLUDES)
-testDoubleAtanh_LDADD = $(check_LDADD)