summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/atanh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/atanh/Makefile.am')
-rw-r--r--src/elementaryFunctions/atanh/Makefile.am24
1 files changed, 15 insertions, 9 deletions
diff --git a/src/elementaryFunctions/atanh/Makefile.am b/src/elementaryFunctions/atanh/Makefile.am
index b3172777..df8d31a3 100644
--- a/src/elementaryFunctions/atanh/Makefile.am
+++ b/src/elementaryFunctions/atanh/Makefile.am
@@ -37,16 +37,22 @@ HEAD = ../includes/atanh.h
check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/type
-check_PROGRAMS = testAtanh
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/elementaryFunctions/atanh/libAtanh.la \
+ @LIBMATH@
+
+check_PROGRAMS = testFloatAtanh testDoubleAtanh
-TESTS = testAtanh
+TESTS = testFloatAtanh testDoubleAtanh
#
-# -*- Atanhgeant Tests -*-
+# -*- Hyperbolic ArcTangeant Tests -*-
#
-testAtanh_SOURCES = testAtanh.c
-testAtanh_CFLAGS = $(check_INCLUDES)
-testAtanh_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/elementaryFunctions/atanh/libAtanh.la \
- @LIBMATH@
+testFloatAtanh_SOURCES = testFloatAtanh.c
+testFloatAtanh_CFLAGS = $(check_INCLUDES)
+testFloatAtanh_LDADD = $(check_LDADD)
+
+testDoubleAtanh_SOURCES = testDoubleAtanh.c
+testDoubleAtanh_CFLAGS = $(check_INCLUDES)
+testDoubleAtanh_LDADD = $(check_LDADD)