summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/atan/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/atan/Makefile.am')
-rw-r--r--src/elementaryFunctions/atan/Makefile.am24
1 files changed, 15 insertions, 9 deletions
diff --git a/src/elementaryFunctions/atan/Makefile.am b/src/elementaryFunctions/atan/Makefile.am
index 28ab854e..07208ce6 100644
--- a/src/elementaryFunctions/atan/Makefile.am
+++ b/src/elementaryFunctions/atan/Makefile.am
@@ -37,16 +37,22 @@ HEAD = ../includes/atan.h
check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/type
-check_PROGRAMS = testAtan
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/elementaryFunctions/atan/libAtan.la \
+ @LIBMATH@
+
+check_PROGRAMS = testFloatAtan testDoubleAtan
-TESTS = testAtan
+TESTS = testFloatAtan testDoubleAtan
#
-# -*- Atangeant Tests -*-
+# -*- Arc tangeant Tests -*-
#
-testAtan_SOURCES = testAtan.c
-testAtan_CFLAGS = $(check_INCLUDES)
-testAtan_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/elementaryFunctions/atan/libAtan.la \
- @LIBMATH@
+testFloatAtan_SOURCES = testFloatAtan.c
+testFloatAtan_CFLAGS = $(check_INCLUDES)
+testFloatAtan_LDADD = $(check_LDADD)
+
+testDoubleAtan_SOURCES = testDoubleAtan.c
+testDoubleAtan_CFLAGS = $(check_INCLUDES)
+testDoubleAtan_LDADD = $(check_LDADD)