summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/asinh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/asinh/Makefile.am')
-rw-r--r--src/elementaryFunctions/asinh/Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/src/elementaryFunctions/asinh/Makefile.am b/src/elementaryFunctions/asinh/Makefile.am
index e84ed15e..91132334 100644
--- a/src/elementaryFunctions/asinh/Makefile.am
+++ b/src/elementaryFunctions/asinh/Makefile.am
@@ -37,16 +37,22 @@ HEAD = ../includes/asinh.h
check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/type
-check_PROGRAMS = testAsinh
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/elementaryFunctions/asinh/libAsinh.la \
+ @LIBMATH@
+
+check_PROGRAMS = testFloatAsinh testDoubleAsinh
-TESTS = testAsinh
+TESTS = testFloatAsinh testDoubleAsinh
#
# -*- Hyperbolic ArcSine Tests -*-
#
-testAsinh_SOURCES = testAsinh.c
-testAsinh_CFLAGS = $(check_INCLUDES)
-testAsinh_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/elementaryFunctions/asinh/libAsinh.la \
- @LIBMATH@ \ No newline at end of file
+testFloatAsinh_SOURCES = testFloatAsinh.c
+testFloatAsinh_CFLAGS = $(check_INCLUDES)
+testFloatAsinh_LDADD = $(check_LDADD)
+
+testDoubleAsinh_SOURCES = testDoubleAsinh.c
+testDoubleAsinh_CFLAGS = $(check_INCLUDES)
+testDoubleAsinh_LDADD = $(check_LDADD) \ No newline at end of file