summaryrefslogtreecommitdiff
path: root/src/auxiliaryFunctions/pythag/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/auxiliaryFunctions/pythag/Makefile.am')
-rw-r--r--src/auxiliaryFunctions/pythag/Makefile.am58
1 files changed, 0 insertions, 58 deletions
diff --git a/src/auxiliaryFunctions/pythag/Makefile.am b/src/auxiliaryFunctions/pythag/Makefile.am
deleted file mode 100644
index 1d68e54a..00000000
--- a/src/auxiliaryFunctions/pythag/Makefile.am
+++ /dev/null
@@ -1,58 +0,0 @@
-##
-## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
-## Copyright (C) 2007-2008 - INRIA - Bruno JOFRET
-##
-## This file must be used under the terms of the CeCILL.
-## This source file is licensed as described in the file COPYING, which
-## you should have received as part of this distribution. The terms
-## are also available at
-## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
-##
-##
-
-libPythag_la_CFLAGS = -I $(top_builddir)/type \
- -I $(top_builddir)/auxiliaryFunctions/includes \
- -I $(top_builddir)/elementaryFunctions/includes \
- -I $(top_builddir)/operations/includes
-
-instdir = $(top_builddir)/lib
-
-pkglib_LTLIBRARIES = libPythag.la
-
-libPythag_la_SOURCES = $(HEAD) $(SRC)
-
-SRC = spythags.c \
- dpythags.c \
- cpythags.c \
- zpythags.c
-
-HEAD = ../includes/pythag.h
-
-####
-# Checking Part
-####
-
-check_INCLUDES = -I $(top_builddir)/auxiliaryFunctions/includes \
- -I $(top_builddir)/elementaryFunctions/includes \
- -I $(top_builddir)/operations/includes \
- -I $(top_builddir)/type
-
-check_PROGRAMS = testPythag
-
-TESTS = testPythag
-
-#
-# -*- Pythag Tests -*-
-#
-testPythag_SOURCES = testPythag.h testPythag.c
-testPythag_CFLAGS = $(check_INCLUDES)
-testPythag_LDADD = $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/operations/addition/libAddition.la \
- $(top_builddir)/lib/lapack/libscilapack.la \
- $(top_builddir)/auxiliaryFunctions/pythag/libPythag.la \
- $(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
- $(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
- $(top_builddir)/auxiliaryFunctions/pythag/libPythag.la \
- $(top_builddir)/operations/multiplication/libMultiplication.la \
- @LIBMATH@