summaryrefslogtreecommitdiff
path: root/src/auxiliaryFunctions/abs/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/auxiliaryFunctions/abs/Makefile.in')
-rw-r--r--src/auxiliaryFunctions/abs/Makefile.in93
1 files changed, 62 insertions, 31 deletions
diff --git a/src/auxiliaryFunctions/abs/Makefile.in b/src/auxiliaryFunctions/abs/Makefile.in
index 6e2e47cb..d3ac9681 100644
--- a/src/auxiliaryFunctions/abs/Makefile.in
+++ b/src/auxiliaryFunctions/abs/Makefile.in
@@ -32,8 +32,8 @@ PRE_UNINSTALL = :
POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
-check_PROGRAMS = testAbs$(EXEEXT)
-TESTS = testAbs$(EXEEXT)
+check_PROGRAMS = testFloatAbs$(EXEEXT) testDoubleAbs$(EXEEXT)
+TESTS = testFloatAbs$(EXEEXT) testDoubleAbs$(EXEEXT)
subdir = auxiliaryFunctions/abs
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
@@ -62,15 +62,22 @@ libAbs_la_OBJECTS = $(am_libAbs_la_OBJECTS)
libAbs_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(libAbs_la_CFLAGS) \
$(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
-am_testAbs_OBJECTS = testAbs-testAbs.$(OBJEXT)
-testAbs_OBJECTS = $(am_testAbs_OBJECTS)
-testAbs_DEPENDENCIES = $(top_builddir)/type/libDoubleComplex.la \
+am_testDoubleAbs_OBJECTS = testDoubleAbs-testDoubleAbs.$(OBJEXT)
+testDoubleAbs_OBJECTS = $(am_testDoubleAbs_OBJECTS)
+am__DEPENDENCIES_1 = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
$(top_builddir)/elementaryFunctions/sqrt/libSqrt.la
-testAbs_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
- --mode=link $(CCLD) $(testAbs_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
- $(LDFLAGS) -o $@
+testDoubleAbs_DEPENDENCIES = $(am__DEPENDENCIES_1)
+testDoubleAbs_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(testDoubleAbs_CFLAGS) \
+ $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+am_testFloatAbs_OBJECTS = testFloatAbs-testFloatAbs.$(OBJEXT)
+testFloatAbs_OBJECTS = $(am_testFloatAbs_OBJECTS)
+testFloatAbs_DEPENDENCIES = $(am__DEPENDENCIES_1)
+testFloatAbs_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(testFloatAbs_CFLAGS) \
+ $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
DEFAULT_INCLUDES = -I. -I$(top_builddir)/includes@am__isrc@
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
am__depfiles_maybe = depfiles
@@ -83,8 +90,10 @@ CCLD = $(CC)
LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
$(LDFLAGS) -o $@
-SOURCES = $(libAbs_la_SOURCES) $(testAbs_SOURCES)
-DIST_SOURCES = $(libAbs_la_SOURCES) $(testAbs_SOURCES)
+SOURCES = $(libAbs_la_SOURCES) $(testDoubleAbs_SOURCES) \
+ $(testFloatAbs_SOURCES)
+DIST_SOURCES = $(libAbs_la_SOURCES) $(testDoubleAbs_SOURCES) \
+ $(testFloatAbs_SOURCES)
ETAGS = etags
CTAGS = ctags
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
@@ -221,18 +230,22 @@ check_INCLUDES = -I $(top_builddir)/auxiliaryFunctions/includes \
-I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/type
-
-#
-# -*- Abs Tests -*-
-#
-testAbs_SOURCES = testAbs.c
-testAbs_CFLAGS = $(check_INCLUDES)
-testAbs_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
$(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
@LIBMATH@
+
+#
+# -*- Abs Tests -*-
+#
+testFloatAbs_SOURCES = testFloatAbs.c
+testFloatAbs_CFLAGS = $(check_INCLUDES)
+testFloatAbs_LDADD = $(check_LDADD)
+testDoubleAbs_SOURCES = testDoubleAbs.c
+testDoubleAbs_CFLAGS = $(check_INCLUDES)
+testDoubleAbs_LDADD = $(check_LDADD)
all: all-am
.SUFFIXES:
@@ -302,9 +315,12 @@ clean-checkPROGRAMS:
echo " rm -f $$p $$f"; \
rm -f $$p $$f ; \
done
-testAbs$(EXEEXT): $(testAbs_OBJECTS) $(testAbs_DEPENDENCIES)
- @rm -f testAbs$(EXEEXT)
- $(testAbs_LINK) $(testAbs_OBJECTS) $(testAbs_LDADD) $(LIBS)
+testDoubleAbs$(EXEEXT): $(testDoubleAbs_OBJECTS) $(testDoubleAbs_DEPENDENCIES)
+ @rm -f testDoubleAbs$(EXEEXT)
+ $(testDoubleAbs_LINK) $(testDoubleAbs_OBJECTS) $(testDoubleAbs_LDADD) $(LIBS)
+testFloatAbs$(EXEEXT): $(testFloatAbs_OBJECTS) $(testFloatAbs_DEPENDENCIES)
+ @rm -f testFloatAbs$(EXEEXT)
+ $(testFloatAbs_LINK) $(testFloatAbs_OBJECTS) $(testFloatAbs_LDADD) $(LIBS)
mostlyclean-compile:
-rm -f *.$(OBJEXT)
@@ -320,7 +336,8 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libAbs_la-sabss.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libAbs_la-zabsa.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libAbs_la-zabss.Plo@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/testAbs-testAbs.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/testDoubleAbs-testDoubleAbs.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/testFloatAbs-testFloatAbs.Po@am__quote@
.c.o:
@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
@@ -399,19 +416,33 @@ libAbs_la-zabsa.lo: zabsa.c
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libAbs_la_CFLAGS) $(CFLAGS) -c -o libAbs_la-zabsa.lo `test -f 'zabsa.c' || echo '$(srcdir)/'`zabsa.c
-testAbs-testAbs.o: testAbs.c
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testAbs_CFLAGS) $(CFLAGS) -MT testAbs-testAbs.o -MD -MP -MF $(DEPDIR)/testAbs-testAbs.Tpo -c -o testAbs-testAbs.o `test -f 'testAbs.c' || echo '$(srcdir)/'`testAbs.c
-@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/testAbs-testAbs.Tpo $(DEPDIR)/testAbs-testAbs.Po
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='testAbs.c' object='testAbs-testAbs.o' libtool=no @AMDEPBACKSLASH@
+testDoubleAbs-testDoubleAbs.o: testDoubleAbs.c
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testDoubleAbs_CFLAGS) $(CFLAGS) -MT testDoubleAbs-testDoubleAbs.o -MD -MP -MF $(DEPDIR)/testDoubleAbs-testDoubleAbs.Tpo -c -o testDoubleAbs-testDoubleAbs.o `test -f 'testDoubleAbs.c' || echo '$(srcdir)/'`testDoubleAbs.c
+@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/testDoubleAbs-testDoubleAbs.Tpo $(DEPDIR)/testDoubleAbs-testDoubleAbs.Po
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='testDoubleAbs.c' object='testDoubleAbs-testDoubleAbs.o' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testDoubleAbs_CFLAGS) $(CFLAGS) -c -o testDoubleAbs-testDoubleAbs.o `test -f 'testDoubleAbs.c' || echo '$(srcdir)/'`testDoubleAbs.c
+
+testDoubleAbs-testDoubleAbs.obj: testDoubleAbs.c
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testDoubleAbs_CFLAGS) $(CFLAGS) -MT testDoubleAbs-testDoubleAbs.obj -MD -MP -MF $(DEPDIR)/testDoubleAbs-testDoubleAbs.Tpo -c -o testDoubleAbs-testDoubleAbs.obj `if test -f 'testDoubleAbs.c'; then $(CYGPATH_W) 'testDoubleAbs.c'; else $(CYGPATH_W) '$(srcdir)/testDoubleAbs.c'; fi`
+@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/testDoubleAbs-testDoubleAbs.Tpo $(DEPDIR)/testDoubleAbs-testDoubleAbs.Po
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='testDoubleAbs.c' object='testDoubleAbs-testDoubleAbs.obj' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testDoubleAbs_CFLAGS) $(CFLAGS) -c -o testDoubleAbs-testDoubleAbs.obj `if test -f 'testDoubleAbs.c'; then $(CYGPATH_W) 'testDoubleAbs.c'; else $(CYGPATH_W) '$(srcdir)/testDoubleAbs.c'; fi`
+
+testFloatAbs-testFloatAbs.o: testFloatAbs.c
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testFloatAbs_CFLAGS) $(CFLAGS) -MT testFloatAbs-testFloatAbs.o -MD -MP -MF $(DEPDIR)/testFloatAbs-testFloatAbs.Tpo -c -o testFloatAbs-testFloatAbs.o `test -f 'testFloatAbs.c' || echo '$(srcdir)/'`testFloatAbs.c
+@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/testFloatAbs-testFloatAbs.Tpo $(DEPDIR)/testFloatAbs-testFloatAbs.Po
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='testFloatAbs.c' object='testFloatAbs-testFloatAbs.o' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testAbs_CFLAGS) $(CFLAGS) -c -o testAbs-testAbs.o `test -f 'testAbs.c' || echo '$(srcdir)/'`testAbs.c
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testFloatAbs_CFLAGS) $(CFLAGS) -c -o testFloatAbs-testFloatAbs.o `test -f 'testFloatAbs.c' || echo '$(srcdir)/'`testFloatAbs.c
-testAbs-testAbs.obj: testAbs.c
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testAbs_CFLAGS) $(CFLAGS) -MT testAbs-testAbs.obj -MD -MP -MF $(DEPDIR)/testAbs-testAbs.Tpo -c -o testAbs-testAbs.obj `if test -f 'testAbs.c'; then $(CYGPATH_W) 'testAbs.c'; else $(CYGPATH_W) '$(srcdir)/testAbs.c'; fi`
-@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/testAbs-testAbs.Tpo $(DEPDIR)/testAbs-testAbs.Po
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='testAbs.c' object='testAbs-testAbs.obj' libtool=no @AMDEPBACKSLASH@
+testFloatAbs-testFloatAbs.obj: testFloatAbs.c
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testFloatAbs_CFLAGS) $(CFLAGS) -MT testFloatAbs-testFloatAbs.obj -MD -MP -MF $(DEPDIR)/testFloatAbs-testFloatAbs.Tpo -c -o testFloatAbs-testFloatAbs.obj `if test -f 'testFloatAbs.c'; then $(CYGPATH_W) 'testFloatAbs.c'; else $(CYGPATH_W) '$(srcdir)/testFloatAbs.c'; fi`
+@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/testFloatAbs-testFloatAbs.Tpo $(DEPDIR)/testFloatAbs-testFloatAbs.Po
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='testFloatAbs.c' object='testFloatAbs-testFloatAbs.obj' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testAbs_CFLAGS) $(CFLAGS) -c -o testAbs-testAbs.obj `if test -f 'testAbs.c'; then $(CYGPATH_W) 'testAbs.c'; else $(CYGPATH_W) '$(srcdir)/testAbs.c'; fi`
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(testFloatAbs_CFLAGS) $(CFLAGS) -c -o testFloatAbs-testFloatAbs.obj `if test -f 'testFloatAbs.c'; then $(CYGPATH_W) 'testFloatAbs.c'; else $(CYGPATH_W) '$(srcdir)/testFloatAbs.c'; fi`
mostlyclean-libtool:
-rm -f *.lo