summaryrefslogtreecommitdiff
path: root/src/statisticsFunctions/mean/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-06-19 09:41:27 +0000
committerjofret2008-06-19 09:41:27 +0000
commit205395e92234946007cb94809abdaf136d0754f4 (patch)
treed88f50ea40ecdc569efa9b458c848b71eb0cc3bb /src/statisticsFunctions/mean/Makefile.am
parentf9b0e9e54c8ebf227d2002bd6a621ef3f2ca1272 (diff)
downloadscilab2c-205395e92234946007cb94809abdaf136d0754f4.tar.gz
scilab2c-205395e92234946007cb94809abdaf136d0754f4.tar.bz2
scilab2c-205395e92234946007cb94809abdaf136d0754f4.zip
- Add mean column and row ways.
- Add huge tests.
Diffstat (limited to 'src/statisticsFunctions/mean/Makefile.am')
-rw-r--r--src/statisticsFunctions/mean/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/statisticsFunctions/mean/Makefile.am b/src/statisticsFunctions/mean/Makefile.am
index 7fac26c5..695ababa 100644
--- a/src/statisticsFunctions/mean/Makefile.am
+++ b/src/statisticsFunctions/mean/Makefile.am
@@ -20,9 +20,17 @@ pkglib_LTLIBRARIES = libMean.la
libMean_la_SOURCES = $(HEAD) $(SRC)
SRC = smeana.c \
+ srowmeana.c \
+ scolumnmeana.c \
dmeana.c \
+ drowmeana.c \
+ dcolumnmeana.c \
cmeana.c \
- zmeana.c
+ crowmeana.c \
+ ccolumnmeana.c \
+ zmeana.c \
+ zrowmeana.c \
+ zcolumnmeana.c
HEAD = ../includes/mean.h
@@ -36,6 +44,7 @@ check_INCLUDES = -I $(top_builddir)/statisticsFunctions/includes \
check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/statisticsFunctions/mean/libMean.la \
+ $(top_builddir)/statisticsFunctions/sum/libSum.la \
@LIBMATH@
check_PROGRAMS = testFloatMean testDoubleMean