summaryrefslogtreecommitdiff
path: root/src/matrixOperations/zeros/Makefile.am
diff options
context:
space:
mode:
authortorset2009-02-10 14:58:14 +0000
committertorset2009-02-10 14:58:14 +0000
commit1cec688873e0bb45f3b73a9b4d37d49e1a4961da (patch)
treecdb80422c0af0bd6d8d80f3b3b1bd84d43536bbb /src/matrixOperations/zeros/Makefile.am
parent5e4a7dab681f8b0bcdbe15a908b38f2e6db36df1 (diff)
downloadscilab2c-1cec688873e0bb45f3b73a9b4d37d49e1a4961da.tar.gz
scilab2c-1cec688873e0bb45f3b73a9b4d37d49e1a4961da.tar.bz2
scilab2c-1cec688873e0bb45f3b73a9b4d37d49e1a4961da.zip
Add zeros files
Diffstat (limited to 'src/matrixOperations/zeros/Makefile.am')
-rw-r--r--src/matrixOperations/zeros/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/matrixOperations/zeros/Makefile.am b/src/matrixOperations/zeros/Makefile.am
new file mode 100644
index 00000000..3faeee86
--- /dev/null
+++ b/src/matrixOperations/zeros/Makefile.am
@@ -0,0 +1,42 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Allan SIMON
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libMatrixZeros_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/matrixOperations/includes
+
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libMatrixZeros.la
+
+HEAD = ../includes/matrixZeros.h
+
+libMatrixZeros_la_SOURCES = $(HEAD) \
+ szerosa.c \
+ dzerosa.c \
+ czerosa.c \
+ zzerosa.c
+
+check_PROGRAMS = testMatrixZeros
+
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ libMatrixZeros.la
+
+check_INCLUDES = -I $(top_builddir)/type \
+ -I $(top_builddir)/matrixOperations/includes
+
+testMatrixZeros_SOURCES = testMatrixZeros.c
+testMatrixZeros_LDADD = $(check_LDADD)
+testMatrixZeros_CFLAGS = $(check_INCLUDES)
+
+TESTS = testMatrixZeros