summaryrefslogtreecommitdiff
path: root/src/matrixOperations/jmat/Makefile.am
diff options
context:
space:
mode:
authortorset2008-11-24 15:12:34 +0000
committertorset2008-11-24 15:12:34 +0000
commitce9bcf768006687a3a491174b687b8de785b90f7 (patch)
tree851093190b51024e8d4ca03f6a2a0efe91484969 /src/matrixOperations/jmat/Makefile.am
parentb35e4a7df2360d7a2d27ae78217230a5d257f60a (diff)
downloadscilab2c-ce9bcf768006687a3a491174b687b8de785b90f7.tar.gz
scilab2c-ce9bcf768006687a3a491174b687b8de785b90f7.tar.bz2
scilab2c-ce9bcf768006687a3a491174b687b8de785b90f7.zip
Update files
Diffstat (limited to 'src/matrixOperations/jmat/Makefile.am')
-rw-r--r--src/matrixOperations/jmat/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/matrixOperations/jmat/Makefile.am b/src/matrixOperations/jmat/Makefile.am
new file mode 100644
index 00000000..4cd7f9e1
--- /dev/null
+++ b/src/matrixOperations/jmat/Makefile.am
@@ -0,0 +1,35 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Arnaud TORSET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libJmat_la_CFLAGS= -I $(top_builddir)/matrixOperations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libJmat.la
+
+HEAD = ../includes/jmat.h
+
+libJmat_la_SOURCES = $(HEAD) \
+ sjmata.c \
+ djmata.c
+
+check_PROGRAMS = testJmat
+
+check_LDADD = libJmat.la
+
+check_INCLUDES = -I $(top_builddir)/matrixOperations/includes
+
+testJmat_SOURCES = testJmat.c
+testJmat_LDADD = $(check_LDADD)
+testJmat_CFLAGS = $(check_INCLUDES)
+
+TESTS = testJmat