summaryrefslogtreecommitdiff
path: root/src/matrixOperations/hilbert/Makefile.am
diff options
context:
space:
mode:
authorsimon2008-07-25 15:23:38 +0000
committersimon2008-07-25 15:23:38 +0000
commit412bc2d86a5147fdcf9d3a5cc29f47a8ecbeaf88 (patch)
treeb1fef5aaeb991421e76b9a365753e3d751029155 /src/matrixOperations/hilbert/Makefile.am
parent5032a2e60f7ec82970eceb5559c7eff177b126ad (diff)
downloadscilab2c-412bc2d86a5147fdcf9d3a5cc29f47a8ecbeaf88.tar.gz
scilab2c-412bc2d86a5147fdcf9d3a5cc29f47a8ecbeaf88.tar.bz2
scilab2c-412bc2d86a5147fdcf9d3a5cc29f47a8ecbeaf88.zip
added functions to generate hilbert matrix
Diffstat (limited to 'src/matrixOperations/hilbert/Makefile.am')
-rw-r--r--src/matrixOperations/hilbert/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/matrixOperations/hilbert/Makefile.am b/src/matrixOperations/hilbert/Makefile.am
new file mode 100644
index 00000000..64f203be
--- /dev/null
+++ b/src/matrixOperations/hilbert/Makefile.am
@@ -0,0 +1,37 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Allan SIMON
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libDSPHilbert_la_CFLAGS = -I $(top_builddir)/type \
+ -I ../includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libDSPHilbert.la
+
+HEAD = ../includes/hilbert.h
+
+libDSPHilbert_la_SOURCES = $(HEAD) \
+ shilba.c \
+ dhilba.c
+
+check_PROGRAMS = testDSPHilbert
+
+check_LDADD = libDSPHilbert.la
+
+check_INCLUDES = -I $(top_builddir)/type \
+ -I ../includes
+
+testDSPHilbert_SOURCES = testDSPHilbert.c
+testDSPHilbert_LDADD = $(check_LDADD)
+testDSPHilbert_CFLAGS = $(check_INCLUDES)
+
+TESTS = testDSPHilbert