summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/sqrt/Makefile.am
diff options
context:
space:
mode:
authorjofret2007-04-20 08:47:10 +0000
committerjofret2007-04-20 08:47:10 +0000
commit253684509ac9a972c5211feb256b8d7c5f8b2051 (patch)
treef86b1af364a96162b082290151f7cdd5d00086ea /src/elementaryFunctions/sqrt/Makefile.am
parent6faf9cc3c16557c5dbfa4f096b6b34f594fe1fd0 (diff)
downloadscilab2c-253684509ac9a972c5211feb256b8d7c5f8b2051.tar.gz
scilab2c-253684509ac9a972c5211feb256b8d7c5f8b2051.tar.bz2
scilab2c-253684509ac9a972c5211feb256b8d7c5f8b2051.zip
Square Root begin implementation.
Diffstat (limited to 'src/elementaryFunctions/sqrt/Makefile.am')
-rw-r--r--src/elementaryFunctions/sqrt/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/elementaryFunctions/sqrt/Makefile.am b/src/elementaryFunctions/sqrt/Makefile.am
index 677a7185..fb8bfba0 100644
--- a/src/elementaryFunctions/sqrt/Makefile.am
+++ b/src/elementaryFunctions/sqrt/Makefile.am
@@ -5,7 +5,7 @@
## Made by Bruno JOFRET <bruno.jofret@inria.fr>
##
## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Sun Mar 25 20:57:17 2007 bruno
+## Last update Fri Apr 20 10:54:14 2007 jofret
##
## Copyright INRIA 2007
##
@@ -31,3 +31,24 @@ SRC = ssqrts.c \
zsqrta.c
HEAD = ../includes/sqrt.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_PROGRAMS = testSqrt
+
+TESTS = testSqrt
+
+#
+# -*- Square Root Tests -*-
+#
+testSqrt_SOURCES = testSqrt.c
+testSqrt_CFLAGS = $(check_INCLUDES)
+testSqrt_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
+ $(top_builddir)/lib/libFloatComplex.a \
+ $(top_builddir)/lib/libSqrt.a \
+ @LIBMATH@