summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/sin/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-04-18 09:38:20 +0000
committerjofret2008-04-18 09:38:20 +0000
commit98bcc0f9668f9ad96ada5fc0cac339f72edd0226 (patch)
treebc4b4f82b3c1b1beb57b62757846fbf9d9b697f7 /src/elementaryFunctions/sin/Makefile.am
parent52b89378bd2c98f37731097673e07daed473e2cf (diff)
downloadscilab2c-98bcc0f9668f9ad96ada5fc0cac339f72edd0226.tar.gz
scilab2c-98bcc0f9668f9ad96ada5fc0cac339f72edd0226.tar.bz2
scilab2c-98bcc0f9668f9ad96ada5fc0cac339f72edd0226.zip
Double vs Float better management. Enable psycho warnings.
Diffstat (limited to 'src/elementaryFunctions/sin/Makefile.am')
-rw-r--r--src/elementaryFunctions/sin/Makefile.am26
1 files changed, 16 insertions, 10 deletions
diff --git a/src/elementaryFunctions/sin/Makefile.am b/src/elementaryFunctions/sin/Makefile.am
index 93c1592b..d350b85f 100644
--- a/src/elementaryFunctions/sin/Makefile.am
+++ b/src/elementaryFunctions/sin/Makefile.am
@@ -37,19 +37,25 @@ HEAD = ../includes/sin.h
check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/type
-check_PROGRAMS = testSin
-
-TESTS = testSin
-
-#
-# -*- Sine Tests -*-
-#
-testSin_SOURCES = testSin.c
-testSin_CFLAGS = $(check_INCLUDES)
-testSin_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/elementaryFunctions/sin/libSin.la \
$(top_builddir)/elementaryFunctions/cos/libCos.la \
$(top_builddir)/elementaryFunctions/sinh/libSinh.la \
$(top_builddir)/elementaryFunctions/cosh/libCosh.la \
@LIBMATH@
+
+check_PROGRAMS = testFloatSin testDoubleSin
+
+TESTS = testFloatSin testDoubleSin
+
+#
+# -*- Sine Tests -*-
+#
+testFloatSin_SOURCES = testFloatSin.c
+testFloatSin_CFLAGS = $(check_INCLUDES)
+testFloatSin_LDADD = $(check_LDADD)
+
+testDoubleSin_SOURCES = testDoubleSin.c
+testDoubleSin_CFLAGS = $(check_INCLUDES)
+testDoubleSin_LDADD = $(check_LDADD)