summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/exp/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-04-21 08:51:00 +0000
committerjofret2008-04-21 08:51:00 +0000
commit734e3acf716a616781097abad96ae95ce4a9dd7c (patch)
tree7fc62d359cf121c76a5a31addf991e3dbf869530 /src/elementaryFunctions/exp/Makefile.am
parentac3ff3769d4abdc84c9bbf507fdafa3dbc137293 (diff)
downloadscilab2c-734e3acf716a616781097abad96ae95ce4a9dd7c.tar.gz
scilab2c-734e3acf716a616781097abad96ae95ce4a9dd7c.tar.bz2
scilab2c-734e3acf716a616781097abad96ae95ce4a9dd7c.zip
Double vs Float better management. Enable psycho warnings.
Diffstat (limited to 'src/elementaryFunctions/exp/Makefile.am')
-rw-r--r--src/elementaryFunctions/exp/Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/src/elementaryFunctions/exp/Makefile.am b/src/elementaryFunctions/exp/Makefile.am
index ca1fbc28..185cb1cb 100644
--- a/src/elementaryFunctions/exp/Makefile.am
+++ b/src/elementaryFunctions/exp/Makefile.am
@@ -37,17 +37,23 @@ HEAD = ../includes/exp.h
check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/type
-check_PROGRAMS = testExp
-
-TESTS = testExp
-
-testExp_SOURCES = testExp.c
-testExp_CFLAGS = $(check_INCLUDES)
-testExp_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/elementaryFunctions/cos/libCos.la \
$(top_builddir)/elementaryFunctions/sin/libSin.la \
$(top_builddir)/elementaryFunctions/cosh/libCosh.la \
$(top_builddir)/elementaryFunctions/sinh/libSinh.la \
$(top_builddir)/elementaryFunctions/exp/libExp.la \
- @LIBMATH@ \ No newline at end of file
+ @LIBMATH@
+
+check_PROGRAMS = testFloatExp testDoubleExp
+
+TESTS = testFloatExp testDoubleExp
+
+testFloatExp_SOURCES = testFloatExp.c
+testFloatExp_CFLAGS = $(check_INCLUDES)
+testFloatExp_LDADD = $(check_LDADD)
+
+testDoubleExp_SOURCES = testDoubleExp.c
+testDoubleExp_CFLAGS = $(check_INCLUDES)
+testDoubleExp_LDADD = $(check_LDADD)