summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/exp/Makefile.am
diff options
context:
space:
mode:
authorjofret2007-04-20 08:32:26 +0000
committerjofret2007-04-20 08:32:26 +0000
commit1f59e1352536bce4c7a9b30a81c84a219efdfe1f (patch)
tree1f8a4af181a93bfa637cde184029628b38e6160e /src/elementaryFunctions/exp/Makefile.am
parent8ebfecf1369d949014e715c98458d6961046084d (diff)
downloadscilab2c-1f59e1352536bce4c7a9b30a81c84a219efdfe1f.tar.gz
scilab2c-1f59e1352536bce4c7a9b30a81c84a219efdfe1f.tar.bz2
scilab2c-1f59e1352536bce4c7a9b30a81c84a219efdfe1f.zip
Adding Automated tests.
Diffstat (limited to 'src/elementaryFunctions/exp/Makefile.am')
-rw-r--r--src/elementaryFunctions/exp/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/src/elementaryFunctions/exp/Makefile.am b/src/elementaryFunctions/exp/Makefile.am
index 3b82230a..6b7a38f9 100644
--- a/src/elementaryFunctions/exp/Makefile.am
+++ b/src/elementaryFunctions/exp/Makefile.am
@@ -5,7 +5,7 @@
## Made by Bruno JOFRET <bruno.jofret@inria.fr>
##
## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Sun Mar 25 20:58:13 2007 bruno
+## Last update Wed Apr 18 17:09:35 2007 jofret
##
## Copyright INRIA 2007
##
@@ -31,3 +31,21 @@ SRC = sexps.c \
zexpa.c
HEAD = ../includes/exp.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_PROGRAMS = testExp
+
+TESTS = testExp
+
+testExp_SOURCES = testExp.c
+testExp_CFLAGS = $(check_INCLUDES)
+testExp_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
+ $(top_builddir)/lib/libFloatComplex.a \
+ $(top_builddir)/lib/libExp.a \
+ @LIBMATH@ \ No newline at end of file