summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/cosh/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-04-11 11:53:16 +0000
committerjofret2008-04-11 11:53:16 +0000
commitf54078f5747edf6114314ccf7c19b7eb7005410f (patch)
treef293dc368fcc253af26b9f8cffa3ff9825854276 /src/elementaryFunctions/cosh/Makefile.am
parent5904efbb93840f489f8f93a12637b8c16be9b0bb (diff)
downloadscilab2c-f54078f5747edf6114314ccf7c19b7eb7005410f.tar.gz
scilab2c-f54078f5747edf6114314ccf7c19b7eb7005410f.tar.bz2
scilab2c-f54078f5747edf6114314ccf7c19b7eb7005410f.zip
libtool management
Diffstat (limited to 'src/elementaryFunctions/cosh/Makefile.am')
-rw-r--r--src/elementaryFunctions/cosh/Makefile.am36
1 files changed, 17 insertions, 19 deletions
diff --git a/src/elementaryFunctions/cosh/Makefile.am b/src/elementaryFunctions/cosh/Makefile.am
index d742e2a3..566d46b9 100644
--- a/src/elementaryFunctions/cosh/Makefile.am
+++ b/src/elementaryFunctions/cosh/Makefile.am
@@ -1,25 +1,23 @@
##
-## -*- makefile -*-
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
##
-## Makefile
-## Made by Bruno JOFRET <bruno.jofret@inria.fr>
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
##
-## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Fri Apr 20 16:42:50 2007 jofret
-##
-## Copyright INRIA 2007
##
-AM_CFLAGS = -I ../../type \
- -I ../includes
+libCosh_la_CFLAGS = -I ../../type \
+ -I ../includes
instdir = $(top_builddir)/lib
-inst_LIBRARIES = libCosh.a
-
-noinst_LIBRARIES = libCosh.a
+pkglib_LTLIBRARIES = libCosh.la
-libCosh_a_SOURCES = $(HEAD) $(SRC)
+libCosh_la_SOURCES = $(HEAD) $(SRC)
SRC = scoshs.c \
dcoshs.c \
@@ -48,10 +46,10 @@ TESTS = testCosh
#
testCosh_SOURCES = testCosh.c
testCosh_CFLAGS = $(check_INCLUDES)
-testCosh_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
- $(top_builddir)/lib/libFloatComplex.a \
- $(top_builddir)/lib/libCosh.a \
- $(top_builddir)/lib/libCos.a \
- $(top_builddir)/lib/libSinh.a \
- $(top_builddir)/lib/libSin.a \
+testCosh_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/elementaryFunctions/cosh/libCosh.la \
+ $(top_builddir)/elementaryFunctions/cos/libCos.la \
+ $(top_builddir)/elementaryFunctions/sinh/libSinh.la \
+ $(top_builddir)/elementaryFunctions/sin/libSin.la \
@LIBMATH@