summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/cosh/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-04-18 09:11:22 +0000
committerjofret2008-04-18 09:11:22 +0000
commitab5ac1b2a3c2c07921aa994dee775ec8e679c447 (patch)
tree7110960da1053525c37a523b731e01daa3d2f95a /src/elementaryFunctions/cosh/Makefile.am
parentf7ae4cce0bc844b137ccce135578c2248a6642b1 (diff)
downloadscilab2c-ab5ac1b2a3c2c07921aa994dee775ec8e679c447.tar.gz
scilab2c-ab5ac1b2a3c2c07921aa994dee775ec8e679c447.tar.bz2
scilab2c-ab5ac1b2a3c2c07921aa994dee775ec8e679c447.zip
Double vs Float better management. Enable psycho warnings.
Diffstat (limited to 'src/elementaryFunctions/cosh/Makefile.am')
-rw-r--r--src/elementaryFunctions/cosh/Makefile.am26
1 files changed, 16 insertions, 10 deletions
diff --git a/src/elementaryFunctions/cosh/Makefile.am b/src/elementaryFunctions/cosh/Makefile.am
index 566d46b9..d3a80988 100644
--- a/src/elementaryFunctions/cosh/Makefile.am
+++ b/src/elementaryFunctions/cosh/Makefile.am
@@ -37,19 +37,25 @@ HEAD = ../includes/cosh.h
check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/type
-check_PROGRAMS = testCosh
-
-TESTS = testCosh
-
-#
-# -*- Hyperbolic Cosine Tests -*-
-#
-testCosh_SOURCES = testCosh.c
-testCosh_CFLAGS = $(check_INCLUDES)
-testCosh_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/elementaryFunctions/cosh/libCosh.la \
$(top_builddir)/elementaryFunctions/cos/libCos.la \
$(top_builddir)/elementaryFunctions/sinh/libSinh.la \
$(top_builddir)/elementaryFunctions/sin/libSin.la \
@LIBMATH@
+
+check_PROGRAMS = testFloatCosh testDoubleCosh
+
+TESTS = testFloatCosh testDoubleCosh
+
+#
+# -*- Hyperbolic Cosine Tests -*-
+#
+testFloatCosh_SOURCES = testFloatCosh.c
+testFloatCosh_CFLAGS = $(check_INCLUDES)
+testFloatCosh_LDADD = $(check_LDADD)
+
+testDoubleCosh_SOURCES = testDoubleCosh.c
+testDoubleCosh_CFLAGS = $(check_INCLUDES)
+testDoubleCosh_LDADD = $(check_LDADD)