summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/cosh/Makefile.am
diff options
context:
space:
mode:
authorjofret2007-04-20 08:30:57 +0000
committerjofret2007-04-20 08:30:57 +0000
commit8ebfecf1369d949014e715c98458d6961046084d (patch)
tree9f5267bd5fd5470ba7127bcb305246ed85b73591 /src/elementaryFunctions/cosh/Makefile.am
parentd6be9cb4ff9d3e5b79346415f2284d45fb27a3c1 (diff)
downloadscilab2c-8ebfecf1369d949014e715c98458d6961046084d.tar.gz
scilab2c-8ebfecf1369d949014e715c98458d6961046084d.tar.bz2
scilab2c-8ebfecf1369d949014e715c98458d6961046084d.zip
Adding Automated tests.
Diffstat (limited to 'src/elementaryFunctions/cosh/Makefile.am')
-rw-r--r--src/elementaryFunctions/cosh/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/elementaryFunctions/cosh/Makefile.am b/src/elementaryFunctions/cosh/Makefile.am
index 7dfb6f40..0eab3cd2 100644
--- a/src/elementaryFunctions/cosh/Makefile.am
+++ b/src/elementaryFunctions/cosh/Makefile.am
@@ -5,7 +5,7 @@
## Made by Bruno JOFRET <bruno.jofret@inria.fr>
##
## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Sun Mar 25 21:01:44 2007 bruno
+## Last update Wed Apr 18 16:45:10 2007 jofret
##
## Copyright INRIA 2007
##
@@ -31,3 +31,24 @@ SRC = scoshs.c \
zcosha.c
HEAD = ../includes/cosh.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_PROGRAMS = testCosh
+
+TESTS = testCosh
+
+#
+# -*- Hyperbolic Cosine Tests -*-
+#
+testCosh_SOURCES = testCosh.c
+testCosh_CFLAGS = $(check_INCLUDES)
+testCosh_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
+ $(top_builddir)/lib/libFloatComplex.a \
+ $(top_builddir)/lib/libCosh.a \
+ @LIBMATH@