summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/cos/Makefile.am
diff options
context:
space:
mode:
authorjofret2007-04-20 08:30:13 +0000
committerjofret2007-04-20 08:30:13 +0000
commitd6be9cb4ff9d3e5b79346415f2284d45fb27a3c1 (patch)
tree4d55007d6b576d659d3ac0d5dd40d6affa5ccd67 /src/elementaryFunctions/cos/Makefile.am
parentcfeba6e9408132a5fa76f0591f15a68339fd8a59 (diff)
downloadscilab2c-d6be9cb4ff9d3e5b79346415f2284d45fb27a3c1.tar.gz
scilab2c-d6be9cb4ff9d3e5b79346415f2284d45fb27a3c1.tar.bz2
scilab2c-d6be9cb4ff9d3e5b79346415f2284d45fb27a3c1.zip
Adding Automated tests.
Diffstat (limited to 'src/elementaryFunctions/cos/Makefile.am')
-rw-r--r--src/elementaryFunctions/cos/Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/src/elementaryFunctions/cos/Makefile.am b/src/elementaryFunctions/cos/Makefile.am
index dbb69da6..28eb3a0a 100644
--- a/src/elementaryFunctions/cos/Makefile.am
+++ b/src/elementaryFunctions/cos/Makefile.am
@@ -5,7 +5,7 @@
## Made by Bruno JOFRET <bruno.jofret@inria.fr>
##
## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Sun Mar 25 21:01:28 2007 bruno
+## Last update Wed Apr 18 16:42:18 2007 jofret
##
## Copyright INRIA 2007
##
@@ -31,3 +31,27 @@ SRC = scoss.c \
zcosa.c
HEAD = ../includes/cos.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_PROGRAMS = testCos
+
+TESTS = testCos
+
+#
+# -*- Cosine Tests -*-
+#
+testCos_SOURCES = testCos.c
+testCos_CFLAGS = $(check_INCLUDES)
+testCos_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
+ $(top_builddir)/lib/libFloatComplex.a \
+ $(top_builddir)/lib/libCos.a \
+ $(top_builddir)/lib/libSin.a \
+ $(top_builddir)/lib/libCosh.a \
+ $(top_builddir)/lib/libSinh.a \
+ @LIBMATH@