summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/asin/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-04-21 15:09:53 +0000
committerjofret2008-04-21 15:09:53 +0000
commit7425dfa5ac9f8f06bea91974960b8af6474fd878 (patch)
tree880ab806e9bbd094eed9faf2655bd9c0a32bd297 /src/elementaryFunctions/asin/Makefile.am
parent9bee1f2a458843199b0541eaf28a7f4d5bbbfa34 (diff)
downloadscilab2c-7425dfa5ac9f8f06bea91974960b8af6474fd878.tar.gz
scilab2c-7425dfa5ac9f8f06bea91974960b8af6474fd878.tar.bz2
scilab2c-7425dfa5ac9f8f06bea91974960b8af6474fd878.zip
Double vs Float better management. Enable psycho warnings.
Diffstat (limited to 'src/elementaryFunctions/asin/Makefile.am')
-rw-r--r--src/elementaryFunctions/asin/Makefile.am28
1 files changed, 17 insertions, 11 deletions
diff --git a/src/elementaryFunctions/asin/Makefile.am b/src/elementaryFunctions/asin/Makefile.am
index d38f5d46..33f1f2cd 100644
--- a/src/elementaryFunctions/asin/Makefile.am
+++ b/src/elementaryFunctions/asin/Makefile.am
@@ -40,16 +40,7 @@ check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
-I $(top_builddir)/auxiliaryFunctions/includes \
-I $(top_builddir)/type
-check_PROGRAMS = testAsin
-
-TESTS = testAsin
-
-#
-# -*- ArcSine Tests -*-
-#
-testAsin_SOURCES = testAsin.c
-testAsin_CFLAGS = $(check_INCLUDES)
-testAsin_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/lib/lapack/libscilapack.la \
$(top_builddir)/lib/blas/libsciblas.la \
@@ -59,4 +50,19 @@ testAsin_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/elementaryFunctions/log/libLog.la \
$(top_builddir)/elementaryFunctions/log1p/libLog1p.la \
$(top_builddir)/elementaryFunctions/atan/libAtan.la \
- @LIBMATH@ \ No newline at end of file
+ @LIBMATH@
+
+check_PROGRAMS = testFloatAsin testDoubleAsin
+
+TESTS = testFloatAsin testDoubleAsin
+
+#
+# -*- ArcSine Tests -*-
+#
+testFloatAsin_SOURCES = testFloatAsin.c
+testFloatAsin_CFLAGS = $(check_INCLUDES)
+testFloatAsin_LDADD = $(check_LDADD)
+
+testDoubleAsin_SOURCES = testDoubleAsin.c
+testDoubleAsin_CFLAGS = $(check_INCLUDES)
+testDoubleAsin_LDADD = $(check_LDADD) \ No newline at end of file