summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/asin/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-04-11 11:38:29 +0000
committerjofret2008-04-11 11:38:29 +0000
commit5a83bc4c1ddd2652e3fee34ab83f05abf2933b36 (patch)
treeb4a72ae8b0baceeed3fd01e6e2361eaaf36f8b53 /src/elementaryFunctions/asin/Makefile.am
parent7fb9153bf6156d73bf4a61fa7f318c6fe661f683 (diff)
downloadscilab2c-5a83bc4c1ddd2652e3fee34ab83f05abf2933b36.tar.gz
scilab2c-5a83bc4c1ddd2652e3fee34ab83f05abf2933b36.tar.bz2
scilab2c-5a83bc4c1ddd2652e3fee34ab83f05abf2933b36.zip
libtool management
improve tests link with scilab algorithm and lapack
Diffstat (limited to 'src/elementaryFunctions/asin/Makefile.am')
-rw-r--r--src/elementaryFunctions/asin/Makefile.am40
1 files changed, 24 insertions, 16 deletions
diff --git a/src/elementaryFunctions/asin/Makefile.am b/src/elementaryFunctions/asin/Makefile.am
index 0992ec71..d38f5d46 100644
--- a/src/elementaryFunctions/asin/Makefile.am
+++ b/src/elementaryFunctions/asin/Makefile.am
@@ -1,25 +1,24 @@
##
-## -*- makefile -*-
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2007-2008 - INRIA - Bruno JOFRET
##
-## Makefile
-## Made by Bruno JOFRET <bruno.jofret@inria.fr>
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
##
-## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Fri Apr 20 10:34:36 2007 jofret
-##
-## Copyright INRIA 2007
##
-AM_CFLAGS = -I ../../type \
- -I ../includes
+libAsin_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/auxiliaryFunctions/includes
instdir = $(top_builddir)/lib
-inst_LIBRARIES = libAsin.a
-
-noinst_LIBRARIES = libAsin.a
+pkglib_LTLIBRARIES = libAsin.la
-libAsin_a_SOURCES = $(HEAD) $(SRC)
+libAsin_la_SOURCES = $(HEAD) $(SRC)
SRC = sasins.c \
dasins.c \
@@ -32,11 +31,13 @@ SRC = sasins.c \
HEAD = ../includes/asin.h
+
####
# Checking Part
####
check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/auxiliaryFunctions/includes \
-I $(top_builddir)/type
check_PROGRAMS = testAsin
@@ -48,7 +49,14 @@ TESTS = testAsin
#
testAsin_SOURCES = testAsin.c
testAsin_CFLAGS = $(check_INCLUDES)
-testAsin_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
- $(top_builddir)/lib/libFloatComplex.a \
- $(top_builddir)/lib/libAsin.a \
+testAsin_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/lib/lapack/libscilapack.la \
+ $(top_builddir)/lib/blas/libsciblas.la \
+ $(top_builddir)/elementaryFunctions/asin/libAsin.la \
+ $(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
+ $(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
+ $(top_builddir)/elementaryFunctions/log/libLog.la \
+ $(top_builddir)/elementaryFunctions/log1p/libLog1p.la \
+ $(top_builddir)/elementaryFunctions/atan/libAtan.la \
@LIBMATH@ \ No newline at end of file