summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/acos/Makefile.am
diff options
context:
space:
mode:
authorjofret2007-04-20 08:29:01 +0000
committerjofret2007-04-20 08:29:01 +0000
commit8e7ea9e904a0e9c5760d2b05de5b3f0af31785de (patch)
tree8bbc6d569d015b1ace8634923366776c18c200fb /src/elementaryFunctions/acos/Makefile.am
parent619b9b1cbc757d4a03984b49fbd8dc6e6c54b638 (diff)
downloadscilab2c-8e7ea9e904a0e9c5760d2b05de5b3f0af31785de.tar.gz
scilab2c-8e7ea9e904a0e9c5760d2b05de5b3f0af31785de.tar.bz2
scilab2c-8e7ea9e904a0e9c5760d2b05de5b3f0af31785de.zip
Adding automated tests.
Diffstat (limited to 'src/elementaryFunctions/acos/Makefile.am')
-rw-r--r--src/elementaryFunctions/acos/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/elementaryFunctions/acos/Makefile.am b/src/elementaryFunctions/acos/Makefile.am
index e5dd6130..38541f43 100644
--- a/src/elementaryFunctions/acos/Makefile.am
+++ b/src/elementaryFunctions/acos/Makefile.am
@@ -5,7 +5,7 @@
## Made by Bruno JOFRET <bruno.jofret@inria.fr>
##
## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Sun Mar 25 21:02:08 2007 bruno
+## Last update Fri Apr 20 10:26:22 2007 jofret
##
## Copyright INRIA 2007
##
@@ -31,3 +31,24 @@ SRC = sacoss.c \
zacosa.c
HEAD = ../includes/acos.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_PROGRAMS = testAcos
+
+TESTS = testAcos
+
+#
+# -*- Acosine Tests -*-
+#
+testAcos_SOURCES = testAcos.c
+testAcos_CFLAGS = $(check_INCLUDES)
+testAcos_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
+ $(top_builddir)/lib/libFloatComplex.a \
+ $(top_builddir)/lib/libAcos.a \
+ @LIBMATH@ \ No newline at end of file