summaryrefslogtreecommitdiff
path: root/src/c/string/disp/Makefile.am
diff options
context:
space:
mode:
authorjofret2010-06-21 06:24:38 +0000
committerjofret2010-06-21 06:24:38 +0000
commit8b44229ef44f0558ce045e46ff833fb44df913c9 (patch)
tree4fdd89b2258c18c905d2f17ef4bea8ea9cf32893 /src/c/string/disp/Makefile.am
parentaf0366230e14cc75d9e9a183375ee9cb69fb46b6 (diff)
downloadscilab2c-release-2.0.tar.gz
scilab2c-release-2.0.tar.bz2
scilab2c-release-2.0.zip
Tagging the 2.0 release of scilab2crelease-2.0
Diffstat (limited to 'src/c/string/disp/Makefile.am')
-rw-r--r--src/c/string/disp/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/c/string/disp/Makefile.am b/src/c/string/disp/Makefile.am
new file mode 100644
index 00000000..bafafee0
--- /dev/null
+++ b/src/c/string/disp/Makefile.am
@@ -0,0 +1,52 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2007-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libDisp_la_CFLAGS = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/string/includes
+
+pkglib_LTLIBRARIES = libDisp.la
+
+libDisp_la_SOURCES = $(HEAD) $(SRC)
+
+SRC = sdisps.c \
+ ddisps.c \
+ cdisps.c \
+ zdisps.c \
+ sdispa.c \
+ ddispa.c \
+ cdispa.c \
+ zdispa.c
+
+HEAD = ../includes/disp.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/src/c/string/includes \
+ -I $(top_builddir)/src/c/type
+
+check_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/c/string/disp/libDisp.la
+
+check_PROGRAMS = testDisp
+
+TESTS = testDisp
+
+#
+# -*- Dispine Tests -*-
+#
+testDisp_SOURCES = testDisp.c
+testDisp_CFLAGS = $(check_INCLUDES)
+testDisp_LDADD = $(check_LDADD)
+