summaryrefslogtreecommitdiff
path: root/src/c/operations/multiplication/Makefile.am
diff options
context:
space:
mode:
authorjofret2009-04-28 06:56:12 +0000
committerjofret2009-04-28 06:56:12 +0000
commit5868a7f86c42335cdad7252ea55117acf7bafe83 (patch)
tree49a1c60045522abf665bfe1e05c5bc7012a5b8e5 /src/c/operations/multiplication/Makefile.am
parent89ce1d449dde70966962946e197c576cf350dc31 (diff)
downloadscilab2c-5868a7f86c42335cdad7252ea55117acf7bafe83.tar.gz
scilab2c-5868a7f86c42335cdad7252ea55117acf7bafe83.tar.bz2
scilab2c-5868a7f86c42335cdad7252ea55117acf7bafe83.zip
Moving source code
Diffstat (limited to 'src/c/operations/multiplication/Makefile.am')
-rw-r--r--src/c/operations/multiplication/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/c/operations/multiplication/Makefile.am b/src/c/operations/multiplication/Makefile.am
new file mode 100644
index 00000000..30ceba9d
--- /dev/null
+++ b/src/c/operations/multiplication/Makefile.am
@@ -0,0 +1,47 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libMultiplication_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/operations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libMultiplication.la
+
+HEAD = ../includes/multiplication.h
+
+libMultiplication_la_SOURCES = $(HEAD) \
+ smuls.c \
+ dmuls.c \
+ cmuls.c \
+ zmuls.c \
+ smula.c \
+ dmula.c \
+ cmula.c \
+ zmula.c \
+ ctimess.c \
+ ztimess.c
+
+check_PROGRAMS = testMultiplication
+
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ libMultiplication.la
+
+check_INCLUDES = -I $(top_builddir)/type \
+ -I $(top_builddir)/operations/includes
+
+testMultiplication_SOURCES = testMultiplication.c
+testMultiplication_LDADD = $(check_LDADD)
+testMultiplication_CFLAGS = $(check_INCLUDES)
+
+TESTS = testMultiplication