summaryrefslogtreecommitdiff
path: root/src/c/matrixOperations/multiplication/Makefile.am
diff options
context:
space:
mode:
authorjofret2009-04-28 06:55:15 +0000
committerjofret2009-04-28 06:55:15 +0000
commit89ce1d449dde70966962946e197c576cf350dc31 (patch)
tree913252b78bddfb80d8a7a98db0592950372f91d0 /src/c/matrixOperations/multiplication/Makefile.am
parent49ad35ec2d8a12428a1613e2a955ddae4195e216 (diff)
downloadscilab2c-89ce1d449dde70966962946e197c576cf350dc31.tar.gz
scilab2c-89ce1d449dde70966962946e197c576cf350dc31.tar.bz2
scilab2c-89ce1d449dde70966962946e197c576cf350dc31.zip
Moving source code
Diffstat (limited to 'src/c/matrixOperations/multiplication/Makefile.am')
-rw-r--r--src/c/matrixOperations/multiplication/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/c/matrixOperations/multiplication/Makefile.am b/src/c/matrixOperations/multiplication/Makefile.am
new file mode 100644
index 00000000..fc852e4f
--- /dev/null
+++ b/src/c/matrixOperations/multiplication/Makefile.am
@@ -0,0 +1,47 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libMatrixMultiplication_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/matrixOperations/includes \
+ -I $(top_builddir)/operations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libMatrixMultiplication.la
+
+HEAD = ../includes/matrixMultiplication.h
+
+libMatrixMultiplication_la_SOURCES = $(HEAD) \
+ smulma.c \
+ dmulma.c \
+ cmulma.c \
+ zmulma.c
+
+check_PROGRAMS = testMatrixMultiplication
+
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/operations/addition/libAddition.la \
+ $(top_builddir)/lib/blas/libsciblas.la \
+ $(top_builddir)/operations/multiplication/libMultiplication.la \
+ libMatrixMultiplication.la
+
+check_INCLUDES = -I $(top_builddir)/type \
+ -I $(top_builddir)/matrixOperations/includes \
+ -I $(top_builddir)/operations/includes
+
+testMatrixMultiplication_SOURCES = testFloatMatrixMultiplication.c \
+ testDoubleMatrixMultiplication.c
+testMatrixMultiplication_LDADD = $(check_LDADD)
+testMatrixMultiplication_CFLAGS = $(check_INCLUDES)
+
+TESTS = testMatrixMultiplication