summaryrefslogtreecommitdiff
path: root/src/c/matrixOperations/fill/Makefile.am
diff options
context:
space:
mode:
authorjofret2009-04-28 06:55:15 +0000
committerjofret2009-04-28 06:55:15 +0000
commit89ce1d449dde70966962946e197c576cf350dc31 (patch)
tree913252b78bddfb80d8a7a98db0592950372f91d0 /src/c/matrixOperations/fill/Makefile.am
parent49ad35ec2d8a12428a1613e2a955ddae4195e216 (diff)
downloadscilab2c-89ce1d449dde70966962946e197c576cf350dc31.tar.gz
scilab2c-89ce1d449dde70966962946e197c576cf350dc31.tar.bz2
scilab2c-89ce1d449dde70966962946e197c576cf350dc31.zip
Moving source code
Diffstat (limited to 'src/c/matrixOperations/fill/Makefile.am')
-rw-r--r--src/c/matrixOperations/fill/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/c/matrixOperations/fill/Makefile.am b/src/c/matrixOperations/fill/Makefile.am
new file mode 100644
index 00000000..29329a53
--- /dev/null
+++ b/src/c/matrixOperations/fill/Makefile.am
@@ -0,0 +1,55 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008 - INRIA - Arnaud TORSET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libMatrixFill_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/matrixOperations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libMatrixFill.la
+
+HEAD = ../includes/fill.h
+
+libMatrixFill_la_SOURCES = $(HEAD) \
+ sfilla.c \
+ dfilla.c \
+ cfilla.c \
+ zfilla.c
+
+
+############
+## CHECK
+############
+
+
+check_PROGRAMS = testDoubleFill testFloatFill
+
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ libMatrixFill.la
+
+check_INCLUDES = -I $(top_builddir)/type \
+ -I $(top_builddir)/matrixOperations/includes
+
+testDoubleFill_SOURCES = testDoubleFill.c
+testDoubleFill_LDADD = $(check_LDADD)
+testDoubleFill_CFLAGS = $(check_INCLUDES)
+
+testFloatFill_SOURCES = testFloatFill.c
+testFloatFill_LDADD = $(check_LDADD)
+testFloatFill_CFLAGS = $(check_INCLUDES)
+
+TESTS = testDoubleFill testFloatFill
+
+
+
+