summaryrefslogtreecommitdiff
path: root/src/c/elementaryFunctions/floor/Makefile.am
diff options
context:
space:
mode:
authorjofret2009-04-28 06:53:00 +0000
committerjofret2009-04-28 06:53:00 +0000
commitb56c1d5508edf80f36c9a48e8806641f5cdf2cd8 (patch)
tree921ff5c8b47befe9b797cffa57bea9c940a7224c /src/c/elementaryFunctions/floor/Makefile.am
parent127ac18608c72acfed9d59599252ad62cb562ee5 (diff)
downloadscilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.tar.gz
scilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.tar.bz2
scilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.zip
Moving source code
Diffstat (limited to 'src/c/elementaryFunctions/floor/Makefile.am')
-rw-r--r--src/c/elementaryFunctions/floor/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/src/c/elementaryFunctions/floor/Makefile.am b/src/c/elementaryFunctions/floor/Makefile.am
new file mode 100644
index 00000000..f16295ef
--- /dev/null
+++ b/src/c/elementaryFunctions/floor/Makefile.am
@@ -0,0 +1,60 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+
+
+libFloor_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/elementaryFunctions/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libFloor.la
+
+libFloor_la_SOURCES = $(HEAD) $(SRC)
+
+HEAD = ../includes/floor.h
+
+SRC = sfloors.c \
+ dfloors.c \
+ cfloors.c \
+ zfloors.c \
+ sfloora.c \
+ dfloora.c \
+ cfloora.c \
+ zfloora.c
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/elementaryFunctions/floor/libFloor.la \
+ @LIBMATH@
+
+check_PROGRAMS = testFloatFloor testDoubleFloor
+
+TESTS = testFloatFloor testDoubleFloor
+
+#
+# -*- Floor Tests -*-
+#
+testFloatFloor_SOURCES = testFloatFloor.c
+testFloatFloor_CFLAGS = $(check_INCLUDES)
+testFloatFloor_LDADD = $(check_LDADD)
+
+testDoubleFloor_SOURCES = testDoubleFloor.c
+testDoubleFloor_CFLAGS = $(check_INCLUDES)
+testDoubleFloor_LDADD = $(check_LDADD)