summaryrefslogtreecommitdiff
path: root/src/c/elementaryFunctions/ceil/Makefile.am
diff options
context:
space:
mode:
authorjofret2009-04-28 06:53:00 +0000
committerjofret2009-04-28 06:53:00 +0000
commitb56c1d5508edf80f36c9a48e8806641f5cdf2cd8 (patch)
tree921ff5c8b47befe9b797cffa57bea9c940a7224c /src/c/elementaryFunctions/ceil/Makefile.am
parent127ac18608c72acfed9d59599252ad62cb562ee5 (diff)
downloadscilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.tar.gz
scilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.tar.bz2
scilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.zip
Moving source code
Diffstat (limited to 'src/c/elementaryFunctions/ceil/Makefile.am')
-rw-r--r--src/c/elementaryFunctions/ceil/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/src/c/elementaryFunctions/ceil/Makefile.am b/src/c/elementaryFunctions/ceil/Makefile.am
new file mode 100644
index 00000000..b3bd3853
--- /dev/null
+++ b/src/c/elementaryFunctions/ceil/Makefile.am
@@ -0,0 +1,60 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+
+
+libCeil_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/elementaryFunctions/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libCeil.la
+
+libCeil_la_SOURCES = $(HEAD) $(SRC)
+
+HEAD = ../includes/ceil.h
+
+SRC = sceils.c \
+ dceils.c \
+ cceils.c \
+ zceils.c \
+ sceila.c \
+ dceila.c \
+ cceila.c \
+ zceila.c
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/elementaryFunctions/ceil/libCeil.la \
+ @LIBMATH@
+
+check_PROGRAMS = testFloatCeil testDoubleCeil
+
+TESTS = testFloatCeil testDoubleCeil
+
+#
+# -*- Ceil Tests -*-
+#
+testFloatCeil_SOURCES = testFloatCeil.c
+testFloatCeil_CFLAGS = $(check_INCLUDES)
+testFloatCeil_LDADD = $(check_LDADD)
+
+testDoubleCeil_SOURCES = testDoubleCeil.c
+testDoubleCeil_CFLAGS = $(check_INCLUDES)
+testDoubleCeil_LDADD = $(check_LDADD)