summaryrefslogtreecommitdiff
path: root/src/auxiliaryFunctions/rand/Makefile.am
diff options
context:
space:
mode:
authorjofret2007-04-18 16:55:20 +0000
committerjofret2007-04-18 16:55:20 +0000
commitc5bfd436e5128eb1c2188104f5dab5dabe35bbd6 (patch)
treeb1e168cc7ac3553645807bfaf36f6a43ddff178a /src/auxiliaryFunctions/rand/Makefile.am
parente5e45b432c54046b734726fa7b979602aa1c2039 (diff)
downloadscilab2c-c5bfd436e5128eb1c2188104f5dab5dabe35bbd6.tar.gz
scilab2c-c5bfd436e5128eb1c2188104f5dab5dabe35bbd6.tar.bz2
scilab2c-c5bfd436e5128eb1c2188104f5dab5dabe35bbd6.zip
Adding Autotools Management.
Diffstat (limited to 'src/auxiliaryFunctions/rand/Makefile.am')
-rw-r--r--src/auxiliaryFunctions/rand/Makefile.am54
1 files changed, 54 insertions, 0 deletions
diff --git a/src/auxiliaryFunctions/rand/Makefile.am b/src/auxiliaryFunctions/rand/Makefile.am
new file mode 100644
index 00000000..950432b3
--- /dev/null
+++ b/src/auxiliaryFunctions/rand/Makefile.am
@@ -0,0 +1,54 @@
+##
+## -*- makefile -*-
+##
+## Makefile
+## Made by Bruno JOFRET <bruno.jofret@inria.fr>
+##
+## Started on Fri Jan 5 10:19:16 2007 jofret
+## Last update Wed Apr 18 18:44:03 2007 jofret
+##
+## Copyright INRIA 2007
+##
+
+AM_CFLAGS = -I ../../type \
+ -I ../includes
+
+instdir = $(top_builddir)/lib
+
+inst_LIBRARIES = libRand.a
+
+noinst_LIBRARIES = libRand.a
+
+libRand_a_SOURCES = $(HEAD) $(SRC)
+
+SRC = srands.c \
+ drands.c \
+ crands.c \
+ zrands.c \
+ sranda.c \
+ dranda.c \
+ cranda.c \
+ zranda.c
+
+HEAD = ../includes/rand.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_PROGRAMS = testRand
+
+TESTS = testRand
+
+#
+# -*- Rand Tests -*-
+#
+testRand_SOURCES = testRand.c
+testRand_CFLAGS = $(check_INCLUDES)
+testRand_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
+ $(top_builddir)/lib/libFloatComplex.a \
+ $(top_builddir)/lib/libRand.a \
+ @LIBMATH@