summaryrefslogtreecommitdiff
path: root/src/auxiliaryFunctions/rand/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-04-11 12:56:34 +0000
committerjofret2008-04-11 12:56:34 +0000
commit931b3660ca515dbd888f316578741db0099056e9 (patch)
tree57760ef22a16de9b567fc6d8d8f2b1d7744d9c9b /src/auxiliaryFunctions/rand/Makefile.am
parent1fd4bb75b1bfdf01f217c1a44faffdac4f247109 (diff)
downloadscilab2c-931b3660ca515dbd888f316578741db0099056e9.tar.gz
scilab2c-931b3660ca515dbd888f316578741db0099056e9.tar.bz2
scilab2c-931b3660ca515dbd888f316578741db0099056e9.zip
Adding tests
Diffstat (limited to 'src/auxiliaryFunctions/rand/Makefile.am')
-rw-r--r--src/auxiliaryFunctions/rand/Makefile.am32
1 files changed, 15 insertions, 17 deletions
diff --git a/src/auxiliaryFunctions/rand/Makefile.am b/src/auxiliaryFunctions/rand/Makefile.am
index 950432b3..95f24f98 100644
--- a/src/auxiliaryFunctions/rand/Makefile.am
+++ b/src/auxiliaryFunctions/rand/Makefile.am
@@ -1,25 +1,23 @@
##
-## -*- makefile -*-
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
##
-## Makefile
-## Made by Bruno JOFRET <bruno.jofret@inria.fr>
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
##
-## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Wed Apr 18 18:44:03 2007 jofret
-##
-## Copyright INRIA 2007
##
-AM_CFLAGS = -I ../../type \
- -I ../includes
+libRand_la_CFLAGS = -I ../../type \
+ -I ../includes
instdir = $(top_builddir)/lib
-inst_LIBRARIES = libRand.a
-
-noinst_LIBRARIES = libRand.a
+pkglib_LTLIBRARIES = libRand.la
-libRand_a_SOURCES = $(HEAD) $(SRC)
+libRand_la_SOURCES = $(HEAD) $(SRC)
SRC = srands.c \
drands.c \
@@ -36,7 +34,7 @@ HEAD = ../includes/rand.h
# Checking Part
####
-check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+check_INCLUDES = -I $(top_builddir)/auxiliaryFunctions/includes \
-I $(top_builddir)/type
check_PROGRAMS = testRand
@@ -48,7 +46,7 @@ TESTS = testRand
#
testRand_SOURCES = testRand.c
testRand_CFLAGS = $(check_INCLUDES)
-testRand_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
- $(top_builddir)/lib/libFloatComplex.a \
- $(top_builddir)/lib/libRand.a \
+testRand_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/auxiliaryFunctions/rand/libRand.la \
@LIBMATH@