summaryrefslogtreecommitdiff
path: root/src/auxiliaryFunctions/conj/Makefile.am
diff options
context:
space:
mode:
authorjofret2008-09-09 13:51:47 +0000
committerjofret2008-09-09 13:51:47 +0000
commitd80697e7ca9932cb408155f7ba9e390a190d91df (patch)
treec4a837bac9c8ef92fc942919a3f945092756ad5b /src/auxiliaryFunctions/conj/Makefile.am
parentcc0ca79aab3b22c23fbb1c7a7e0dec1c26418d16 (diff)
downloadscilab2c-d80697e7ca9932cb408155f7ba9e390a190d91df.tar.gz
scilab2c-d80697e7ca9932cb408155f7ba9e390a190d91df.tar.bz2
scilab2c-d80697e7ca9932cb408155f7ba9e390a190d91df.zip
Moving Conjugate to auxiliary
Diffstat (limited to 'src/auxiliaryFunctions/conj/Makefile.am')
-rw-r--r--src/auxiliaryFunctions/conj/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/auxiliaryFunctions/conj/Makefile.am b/src/auxiliaryFunctions/conj/Makefile.am
new file mode 100644
index 00000000..22a85a74
--- /dev/null
+++ b/src/auxiliaryFunctions/conj/Makefile.am
@@ -0,0 +1,50 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Allan SIMON
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libConj_la_CFLAGS = -I $(top_builddir)/type \
+ -I ../includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libConj.la
+
+HEAD = ../includes/conj.h
+
+libConj_la_SOURCES = $(HEAD) \
+ cconja.c \
+ zconja.c \
+ zconjs.c \
+ cconjs.c
+
+check_PROGRAMS = testConj
+
+check_LDADD = libConj.la \
+ $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/operations/addition/libAddition.la \
+ $(top_builddir)/lib/lapack/libscilapack.la \
+ $(top_builddir)/elementaryFunctions/atan/libAtan.la \
+ $(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
+ $(top_builddir)/elementaryFunctions/atan2/libAtan2.la \
+ $(top_builddir)/elementaryFunctions/lnp1m1/libLnp1m1.la \
+ $(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
+ $(top_builddir)/auxiliaryFunctions/pythag/libPythag.la
+
+
+check_INCLUDES = -I $(top_builddir)/type \
+ -I ../includes
+
+testConj_SOURCES = testConj.c
+testConj_LDADD = $(check_LDADD)
+testConj_CFLAGS = $(check_INCLUDES)
+
+TESTS = testConj