summaryrefslogtreecommitdiff
path: root/query/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'query/CMakeLists.txt')
-rw-r--r--query/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/query/CMakeLists.txt b/query/CMakeLists.txt
new file mode 100644
index 0000000..f9a855e
--- /dev/null
+++ b/query/CMakeLists.txt
@@ -0,0 +1,28 @@
+########################################################################
+# Install rules
+########################################################################
+include(GrPython)
+
+GR_PYTHON_INSTALL(
+ FILES
+ __init__.py
+ DESTINATION ${GR_PYTHON_DIR}/gras/query
+ COMPONENT ${GRAS_COMP_PYTHON}
+)
+
+INSTALL(
+ FILES
+ main.html
+ main.js
+ utils.js
+ chart_factory.js
+ chart_overhead_compare.js
+ chart_overall_throughput.js
+ chart_handler_breakdown.js
+ chart_port_counters.js
+ chart_global_counters.js
+ chart_port_downtime.js
+ main.css
+ DESTINATION ${GR_PYTHON_DIR}/gras/query
+ COMPONENT ${GRAS_COMP_PYTHON}
+)