summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 76e4f2d..ade4f82 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -21,9 +21,6 @@ include_directories(${THERON_INCLUDE_DIRS})
link_directories(${THERON_LIBRARY_DIRS})
add_definitions(${THERON_DEFINES})
-#put custom allocator first into the sources list to guarantee precedence
-list(APPEND GRAS_SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/theron_allocator.cpp)
-
list(APPEND GRAS_LIBRARIES ${THERON_LIBRARIES})
list(APPEND GRAS_SOURCES ${THERON_SOURCES})
@@ -59,6 +56,7 @@ list(APPEND GRAS_SOURCES
${CMAKE_CURRENT_SOURCE_DIR}/top_block.cpp
${CMAKE_CURRENT_SOURCE_DIR}/top_block_stats.cpp
${CMAKE_CURRENT_SOURCE_DIR}/register_messages.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/theron_allocator.cpp
)
########################################################################