summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef24ec1..dad3ac4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,7 +108,9 @@ add_subdirectory(cmake/Modules)
########################################################################
# add gnuradio as sub-project
########################################################################
-set(GRDIR gr36)
+if(NOT GRDIR)
+ set(GRDIR gr36)
+endif()
set(CMAKE_SOURCE_DIR ${GRAS_SOURCE_DIR}/${GRDIR})
set(CMAKE_BINARY_DIR ${GRAS_BINARY_DIR}/${GRDIR})