summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9703923..fa15891 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,23 @@ set(GRAS_VERSION "0.0.0")
set(GRAS_SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR})
set(GRAS_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR})
+function(GRAS_CHECK_SUBMODULE directory)
+ if(NOT EXISTS ${GRAS_SOURCE_DIR}/${directory})
+ message(FATAL_ERROR "
+submodule ${directory} does not exist!!
+Did you remember to run the following commands?
+ git submodule init
+ git submodule update
+")
+ endif()
+endfunction(GRAS_CHECK_SUBMODULE)
+
+GRAS_CHECK_SUBMODULE(Theron)
+GRAS_CHECK_SUBMODULE(Apology)
+GRAS_CHECK_SUBMODULE(PMC)
+GRAS_CHECK_SUBMODULE(gnuradio)
+GRAS_CHECK_SUBMODULE(grextras)
+
list(APPEND CMAKE_MODULE_PATH ${GRAS_SOURCE_DIR}/PMC/cmake/Modules)
include(CMakeDefsHelper)