summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2013-03-18 01:02:55 -0700
committerJosh Blum2013-03-18 01:02:55 -0700
commit84effc390649937ab2f79bbfdf56a00dba38569e (patch)
tree14876e80e0a2fb6d85d499de97016cda3adc4b8f /tests/CMakeLists.txt
parentf94447d4f008290e45dabdd6b9d59c76733b1b4e (diff)
downloadsandhi-84effc390649937ab2f79bbfdf56a00dba38569e.tar.gz
sandhi-84effc390649937ab2f79bbfdf56a00dba38569e.tar.bz2
sandhi-84effc390649937ab2f79bbfdf56a00dba38569e.zip
gras: tweaks to unit tests
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 9393afe..516dd79 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -20,6 +20,7 @@ set(test_sources
include_directories(${GRAS_INCLUDE_DIRS})
include_directories(${Boost_INCLUDE_DIRS})
link_directories(${Boost_LIBRARY_DIRS})
+list(APPEND GR_TEST_LIBRARY_DIRS ${Boost_LIBRARY_DIRS})
#turn each test cpp file into an executable with an int main() function
add_definitions(-DBOOST_TEST_DYN_LINK -DBOOST_TEST_MAIN)
@@ -29,7 +30,6 @@ foreach(test_source ${test_sources})
get_filename_component(test_name ${test_source} NAME_WE)
add_executable(${test_name} ${test_source})
target_link_libraries(${test_name} ${Boost_LIBRARIES} ${GRAS_LIBRARIES})
- set(GR_TEST_LIBRARY_DIRS ${Boost_LIBRARY_DIRS})
GR_ADD_TEST(${test_name}_cpp ${test_name})
endforeach(test_source)