summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2013-07-27 01:17:46 -0700
committerJosh Blum2013-07-27 01:17:46 -0700
commit7a677f768094fecfbb04e7b803c99cc2787153a2 (patch)
tree347e4bd306307bd0f9c979518f840bab00da5488 /tests/CMakeLists.txt
parentb877d078b11cb848b344f4f7534398f70157aa15 (diff)
downloadsandhi-7a677f768094fecfbb04e7b803c99cc2787153a2.tar.gz
sandhi-7a677f768094fecfbb04e7b803c99cc2787153a2.tar.bz2
sandhi-7a677f768094fecfbb04e7b803c99cc2787153a2.zip
gras: work on module loading and python factory
naming convention, path convention, env var convention, And, make a python factory -- but its a little halfassed. You see, we didnt do the swig director thing yet, so C++ cant yet create python blocks from the factory.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 5c76dbe..3c82320 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -4,6 +4,10 @@
include(GrTest)
+#define these blank so they dont interfere with tests
+list(APPEND GR_TEST_ENVIRONS "GRAS_ROOT=")
+list(APPEND GR_TEST_ENVIRONS "GRAS_PATH=")
+
########################################################################
# unit test suite
########################################################################
@@ -64,4 +68,5 @@ file(TO_NATIVE_PATH "${example_module_location}" example_module_location)
message(STATUS "example_module_location: ${example_module_location}")
list(APPEND GR_TEST_ENVIRONS "GRAS_MODULE_PATH=${example_module_location}")
+list(APPEND GR_TEST_ENVIRONS "GRAS_PYTHON_PATH=${CMAKE_CURRENT_SOURCE_DIR}/example_module.py")
GR_ADD_TEST(module_loader_test ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/module_loader_test.py)