summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2013-07-14 13:06:49 -0700
committerJosh Blum2013-07-14 13:06:49 -0700
commit6f9ab7732da5731ee0db59d9623111b7af9b2e94 (patch)
tree72b0a25f5ed1f77be144d011b5c5d7df4f9b0cdf /tests/CMakeLists.txt
parentebb794f538612633d8018922eda4e6ac84b6d585 (diff)
downloadsandhi-6f9ab7732da5731ee0db59d9623111b7af9b2e94.tar.gz
sandhi-6f9ab7732da5731ee0db59d9623111b7af9b2e94.tar.bz2
sandhi-6f9ab7732da5731ee0db59d9623111b7af9b2e94.zip
gras: fixed allocation override bug + unit test
When multiple consumers all choose to override the buffer, they were doing so with the same token, this lead to some buffer allocation confusion and nasty errors. Its ok for one to win out, but each allocator needs a unique token. There is also a unit test to check for this behaviour.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index f74a6c7..f72dfab 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -19,6 +19,7 @@ set(test_sources
block_calls_test.cpp
factory_test.cpp
serialize_tags_test.cpp
+ live_connect_test.cpp
)
include_directories(${GRAS_INCLUDE_DIRS})