summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2013-04-10 00:21:31 -0700
committerJosh Blum2013-04-10 00:21:31 -0700
commitfb55fd6737902ed6270c2518bdc81a6971f9b3a1 (patch)
treec31dcb488f97f4c016ad326c726d5f42bcb6bca0 /lib/CMakeLists.txt
parentca4819c56e7f085c1358cd75a9f4635ce3ae2f1f (diff)
downloadsandhi-fb55fd6737902ed6270c2518bdc81a6971f9b3a1.tar.gz
sandhi-fb55fd6737902ed6270c2518bdc81a6971f9b3a1.tar.bz2
sandhi-fb55fd6737902ed6270c2518bdc81a6971f9b3a1.zip
gras: formalize the weak container api w/ docs
address issue #69, we now have a set_container call, which is now formally part of the api. Anyone can call set_container for custom container types. GRAS supports shared ptr and pyobject out of the box.
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index ff36a5a..5d059e7 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -58,6 +58,7 @@ list(APPEND GRAS_SOURCES
${CMAKE_CURRENT_SOURCE_DIR}/top_block_query.cpp
${CMAKE_CURRENT_SOURCE_DIR}/register_messages.cpp
${CMAKE_CURRENT_SOURCE_DIR}/theron_allocator.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/weak_container.cpp
)
########################################################################